Print this page

Salesforce for Outlook sync creates blank records in Outlook

Knowledge Article Number 000003662
Description

Issue


Sometimes Salesforce for Outlook (SFO) may create blank records in Outlook when synchronizing with Salesforce. Blank records such as blank Contacts or Events with no subject or other information except the date, get created and seems like it is going into a loop mode and keeps creating these events until Salesforce for Outlook finishes the sync or fails.


Users may see the following error messages in the Trace or Sync log or by clicking on the SFO red system tray icon, when they try to synchronize their Outlook using the Salesforce for Outlook plug-in. 

 
ERROR syncengine      [Contact] Create to Outlook gave error(s) Sfdc.Outlook.OLCreateUpdateException 
Interface not supportedOutlook Error:MapiUnknownError --->
 
ERROR outlooksession  EventRDORecordConverter::CreateRecord failed -
Unable to cast COM object of type 'Microsoft.Office.Interop.Outlook.ApplicationClass' to interface type
 'Microsoft.Office.Interop.Outlook._Application'. This operation failed because the QueryInterface call on the COM
 component for the interface with ID '{00063001-0000-0000-C000-000000000046}' failed due to the following
 error: Error loading type library/DLL. (Exception from HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY)).


 
 
 
"http://schemas.microsoft.com/mapi/proptag/0x66700102", EntryID, MessageClass from Folder where (("http://schemas.microsoft.com/mapi/id/{00062002-0000-0000-C000-000000000046}/0x820E0040" >= '2011-08-08 07:00:00') AND ((IsRecurring IS NULL) OR (IsRecurring = 'false'))) AND




 
CAUSE
 

Presumably, the Com interop layer is hitting the registry to try to locate the typelib.  It would start by looking under HKCR\Interface\{00063001-0000-0000-C000-000000000046}\Typelib or …{00062002-0000-0000, etc
 

The default value should refer to installed version of Microsoft Outlook. There should be a version subkey for the installed version of Microsoft Outlook. Removing an Office version (such as Office 2010)  and installing an older one, or installing a new version of Office (for instance, installing Office 2010 while you had Office 2007 installed) and then uninstalling it leaves an extra subkey here which may cause Salesforce for Outlook to fail to sync or generate blank records.
 

User-added image


The screen shot above is from a computer with Outlook 2007 installed -  As you see the 9.3 key on the right side refers to the Outlook 2007 likewise, for Outlook2010 this value would have been 9.4 and for Outlook2016 it would be 9.6. Also there are no other duplicates

This could be the main reason but removing the extra key may require a repair on MS Office to make sure the application updates all the reference keys in the registry

We recommend the following steps to address this issue

 

1- An installation issue with Microsoft Outlook - Mostly the Outlook has a problem with typelib registration

2- Missing or corrupted Outlook data file

3- Duplicated Redemption keys

4- The Redemption keys in the registry are corrupted

5- Duplicated Office Library files that point to different version of Outlook

6- If user is on Windows 7, the User Account Control is set to high (see KB 000019209 )

7- Missing Service Pack from Outlook

Resolution

We need to look at the SFO log files first to see what registry keys besides the one explained above, could cause this issue

Important - Make sure to follow the steps in the order they are listed, for example, you should not run a repair on office before deleting the extra/duplicated keys from the registry

** NOTE
THE BELOW INVOLVES USING THE REGISTRY EDITOR

 

If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system.

See the article
http://support.microsoft.com/kb/322756
to backup the registry on your machine or ask one of your IT team members to perform the following tasks


Step 1


1- First, you probably need to set the User Account Control (UAC) to "Never Notify" in Windows Vista,7, and 8.

2- To do this, close Salesforce for Outlook plug-in from the system tray icon by right clicking on it and clicking on EXIT, close Microsoft Outlook and all other programs

3- then see the steps in the
Article Number     000019209



Now that we set the UAC to Never Notify, we are ready to begin

We need to check the registry for a few keys
 

1- Any duplicated Office Library files that point to different version of Outlook


To open the Registry Editor press the Win(key) + R key combination on your keyboard (see image below)  and type REGEDIT and press Enter

Win key on your keyboard

 

User-added image

In the Registry Editor navigate to

HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}


Under this key you should see one key only that corresponds to the version of Microsoft Outlook you have installed.
 
9.2       for       Office 2003
9.3       for       Office 2007
9.4       for       Office 2010
9.5       for       Office 2013
 
 
For example, if you had Office 2007 on your computer and then installed Outlook (or Office) 2010 and the uninstalled the 2010 version and started using the outlook 2007 again. Sometimes the uninstaller does not remove the corresponding key. So you would need to keep the 9.3 key and remove the 9.4 key.
 
If there is only one entry here,  skip to the next step. ** DO NOT close the Registry Editor yet

Example: User has only Outlook 2007 installed hence the 9.3 key
User-added image

Example: Incorrect entry, user has Outlook 2010 but there are two entries. You need to right click on the 9.3 key (that refers to Outlook 2007) and click on Delete
 
User-added image

 

2- Next delete the following key(s) from the registry as well and then close the Registry (There might be more than 1 Redemption entry, delete them all) No need to save them

 HKEY_CURRENT_USER\Software\Redemption
HKEY_CURRENT_USER\Software\Redemption *
HKEY_CURRENT_USER\Software\Redemption * *
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Redemption

3- Duplicated Redemption keys
When you install SFO, a redemption key that indicates the version of the Redemption is inserted in the registry. A duplicated version could cause a problem. In the Registry Editor, navigate to
HKEY_CLASSES_ROOT\TypeLib\{2D5E2D34-BED5-4B9F-9793-A31E26E6806E}

and make sure you have only 1 key starting with 5.x

Example 1 : This is what you should see. 5.4 is the correct version of SFO
 
User-added image

Example 2 : This example shows you a duplicate entry. You have 2 entries starting with 5.

One is 5.2 and another 5.4
You need to right click on the 5.2 or any other key that you may see starting with 5 and click on Export, to save it on your computer then right click on it again and click on Delete


Again, the 5.4 key is the key you want to keep

You can leave the 4.5 key alone


Keep the Registry Editor open, you will need it for the next step

User-added image

 

STEP 2

Now we need to look at the SFO logs and get the error messages that reference a registry key entry and then do a search for these error messages in the Registry and delete them

To view the SFO Trace.log or Sync.log, click on Start and type in %appdata%\salesforce.com\Salesforce for Outlook in the Search box or use the Win(key) + R key combination on your keyboard to pop up the RUN command and then type in %appdata%\salesforce.com\Salesforce for Outlook in the Search


Open each log and search for {000 using the Ctrl+F key combination (or Click on Edit  and click on Find) and take notes of these numbers then in the Registry Editor, click on the "My Computer" icon on top of the left pane and then click on Edit | Find and search for each one of these keys. There may be multiple instances so you will need to use F3 key on your keyboard to find the next one

For example. If the error message in the sync or trace log shows:


ERROR outlooksession EventRDORecordConverter::CreateRecord failed - Retrieving the COM class factory for component with CLSID {0006F03A-0000-0000-C000-000000000046} failed due to the following error: 80080005

Type in 0006F03A and click on Find, once this key is found on the left pane, right click on the yellow folder on the left and click on Export and save it on your Desktop or any folder (to backup this entries before we delete it). After you save it, right click on it again and click on Delete to remove the key. You need to press the F3 key on your keyboard or click on 'Edit + Find Next' from the Registry to continue the search. Repeat the steps above for the rest of the keys found in the registry

You can close the Registry Editor now

 

Step 3 - Uninstallation of SFO and its components and Repairing Microsoft Office

Now we need to uninstalled the following applications from the Control Panel:

Salesforce for Outlook
Microsoft office 20xx* Primary Interop Assemblies   (*either 2007 or 2010)
Visual Studio 2005 or 2010 Tools for Office Second Edition Runtime


Next you would need to run a Repair on your Microsoft Office installation. If you have different versions of Microsoft Office, make sure to repair the version that includes Microsoft Outlook

Note**
The .Net Programmability Support for Microsoft Office is required for SFO to function properly. This is a feature of the Microsoft Office Installation.

You need to make sure this option is ON for Microsoft Outlook

You can add this feature first then run a repair

 
This is an example in Office 2013, the same option is available in all versions of Office


Note**
If you have versions of Microsoft Office 365 you will see the option to repair only when you click on the Change option from Control Panel list of installed Programs. You will need to select Online Repair option and wait till its done
User-added image


See the link below by Microsoft on how to Install or remove individual Office programs and components


Refer to the link below from Microsoft for more information on repairing MS Office  - http://office.microsoft.com/en-us/starter-help/update-repair-or-uninstall-office-click-to-run-products-HA010382089.aspx

 *You need to restart your computer to make sure changes take effect. Do NOT skip this step


After you restart make sure you have the latest Microsoft Office Service Pack installed.

Download Locations for Microsoft Office Service Packs

 

Microsoft
Office Version

Service
Pack

Size
(MB)

 

Download

Office 2013

SP1

643.6

32-bit

SP1

774.0

Office 2010

SP2

638.2

32-bit

SP2

730.4

64-bit

Office 2007

SP3

351.0

32-bit




Step 4

In this step we need to clean up SFO previous data base and also the blank records that were created in Outlook or/and Salesforce

Open Outlook and change the view to List view so you can sort out the Contacts or Events by Subject and remove all the blank Events if there are any.

Here you can highlight all records at once and delete them.

If many Blank records exist in Salesforce as an Administrator log in to Salesforce and use the Mass Delete Record feature, set the filter to 

subject       > equal >                    (leave blank)


click on search to list all the events with blank subject that were created in Salesforce and then delete them

Now that we have removed all the blank records, we are almost done. One last task would be to delete or rename the folder below

 


Again, use the Win(key) + R key combination on your keyboard to pop up the RUN command and then type in %appdata%\salesforce.com\  
and delete or rename the Salesforce for Outlook folder
 

Step 5

If you are running Outlook in a non Exchange cache mode, there wont be a data file on your computer and in certain cases, due to security settings, non 3rd party applications such as SFO are allowed to write to the Outlook data file (user mailbox) on the Exchange server. We recommend enabling the Exchange cache mode so a copy of the data file gets downloaded to the computer's local disk for access

See Article Number     000188551

If Outlook is already running in the Exchange cached mode, you would need to recreate the file to make sure the data file is intact and not corrupted

See STEP 2 in
Article Number     000028644

 

Step 6

 

Now, that Outlook has been repaired and the Outlook data file has been fully download/recreated (Outlook shows all folders are up to date) you can download and install the “Salesforce for Outlook”.

 

TO INSTALL SALESFORCE FOR OUTLOOK

1. Log into your Salesforce account and click on


SALESFORCE FOR OUTLOOK | DOWNLOAD  in the middle click on DESKTOP  ADD-ONS on the left and under the YOUR NAME | MY SETTINGS | DESKTOP  ADD-ONS

Do not run it, Save it to your computer first. Close Microsoft Outlook and then install it. Once done, open Outlook and configure your SFO and try to reproduce the issue


 

 




promote demote