Print this page

Why is the Salesforce button missing in Microsoft Word or Excel when Office Edition is installed

Knowledge Article Number 000003880
Description

There are times when Salesforce Button is missing in Microsoft Word or Excel when office edition is installed.

Here are the behaviors that causes the button to disappear:

1. When Connect for Microsoft Office is installed on either Microsoft Office 2003 or 2007, the user may not see the plug-in features available in Microsoft Word and or Excel. In MS Word and Excel 2003 the user should see a toolbar button and in Word and Excel 2007 a 'Salesforce.com' tab:

2. When you start Microsoft Word/Excel for the first time after installing the Connect for Office, a ‘Security Warning’ window pops up prompting the user to ‘Disable Macros’. If user press the Enter key on the keyboard or accidently click on the ‘Disable Macros’ button, Microsoft Word or Excel will disable the Salesforce plug-in.

On the Security Warning’ window pops up window user must check the box for ‘Always trust macros from this publisher’ and click on ‘Enable Macros’ button.
If you are having trouble retaining or viewing the Connect for Office toolbar "Icon" in Word or Excel 2003 

 

Resolution

Behavior 1 steps to resolve for Word / Excel 2007

  • From Microsoft Word/Excel click on the office logo on top and click on “Word Options”/ “Excel Options”
  • Click on “Trust Center” and click on “Trust Center Settings”
  • Click on “Trusted Location” and click on “Add new location”
  • Click on Browse and navigate
For Word: Navigate to C:\Program Files\Microsoft Office\Office12\Startup and click on OK
For Excel: Navigate to C:\Program Files\Microsoft Office\Office12\XLSTART and click on OK
 
*If you are using a 64bit version of Microsoft Windows, you would need to browse and navigate to the following 2 folders instead
 
For Word: Navigate to C:\Program Files (x86)\Microsoft Office\Office12\Startup and click on OK
For Excel: Navigate to C:\Program Files (x86)\Microsoft Office\Office12\XLSTART and click on OK
Once you install the Connect for Office, 2 files are placed in each one of these folder so you need to make sure that the
sforce.dot AND sforce12.dotm
exist in the …\Office12\Startup folder and
SFDC.xla AND SFDC12.xlam
 In the …\Office12\ XLSTART folder
 
  • Then click on “Macro Settings” on the left and select the “Enable all macros…” radio button as you see on the image below and click on OK
  • Next click on “okay” to go back to “Word Options” / “Excel Options” again
  • Now click on “Add-Ins” and next to the “Manage” drop down click on “Disabled items” and click on ‘Go”
  • You should see the Salesforce add-ins in the Disabled items list, click on each one of them and click on Enable
  • Click on Close and click on okay
 
NEXT STEP
  • Make sure Microsoft Office applications are closed and then go to Control
  • In Windows XP, you click on “Add/Remove programs” or if you have Windows Vista or Windows 7, click on “Programs and Features”
  • Locate and select the “Salesforce Office Edition” and click on Uninstall
  • Now you would need to reinstall the Salesforce Office Edition.
  •  if you don’t have the installation file, you need to login to Salesforce and download it from Setup | Personal Setup | Desktop Integration | Connect for Office
  • Do not click on the “Install Now” button; instead download the file from the third paragraph as you see in the image below.
  • Run the setup.exe file that have downloaded for Salesforce Office Edition and finish the installation.
 
Alternatively, click here to download the installer to your desktop. Once the file has been transferred, install Connect for Office by double-clicking the file.
 
Behavior 2 steps to resolve for Word / Excel 2003
When you start Microsoft Word/Excel for the first time after installing the Connect for Office, a ‘Security Warning’ window pops up prompting the user to ‘Disable Macros’. If user press the Enter key on the keyboard or accidently click on the ‘Disable Macros’ button, Microsoft Word or Excel will disable the Salesforce plug-in.
On the Security Warning’ window pops up window user must check the box for ‘Always trust macros from this publisher’ and click on ‘Enable Macros’ button.
If you are having trouble retaining or viewing the Connect for Office toolbar "Icon" in Word or Excel 2003 the following may help get them back.
 
Step A
The Office Edition plug-in may have been disabled during the installation and you may need to manually enable it. To do this:

1. Open Microsoft Word and go to Help | About Microsoft Office Word

2. Click the "Disabled Items" Button.

3. Highlight the sforce.dot item and click the "Enable" button then click "OK".

4. You need to restart Microsoft Word
5. Now the toolbar should be visible.
If you are still unable to see the toolbar move to Step B

Step B

1. In Microsoft Word go to the menu View | Toolbars
2. Ensure that the ‘Salesforce Office Edition Word (or Excel) Add-in’ is selected. You can select and deselect and select again if you want to try to get the icon visible.
If you are still unable to see the toolbar move to Step C


Step C:
For Word 2003
  1. If you don't see this toolbar in the list then to go the menu Tools | Templates and Add-Ins
  2. It should show a list of templates and add-ins. The sforce.dot add-in should have been selected. If it isn't, select it.

    ** Sometimes it will be unchecked, but when you try to enable it, you get a message to the effect that it had caused a problem before, and asks whether or not you still want to enable this functionality. Say yes to this message.

     
**Note**
The Connect for Office toolbar will not be visible in Microsoft Word 2003 if you started Microsoft Outlook 2003 before Microsoft Word 2003 and you have Microsoft Word as the default email editor. There is a known issue in Microsoft Word 2003 that affects all Visual Basic based macros.
To manually enable the sforce macro in Microsoft Word:
1. In Microsoft Word, click on Tools | Macro | Macros
2. Highlight the InitApplication row and click on "Run".


You can also start Microsoft Word 2003 before you start Microsoft Outlook 2003 or disable Microsoft Word as your default outlook email editor by going to  Tools | Options | Mail Format tab and uncheck the box for “Use Microsoft Office Word 2003 to edit e-mail messages
Also as I explained earlier, Macro Security causes the Salesforce Office Connect toolbar to appear the first time Word or Excel is run but will make the Salesforce Office Connect toolbar disappear after that.  Likewise, if Office Connect is installed with the Macro Security set to High, it will hide the object from the Disabled Macros window so you will need to completely remove Office Connect if this is the case.  This works for both Excel 2003 and Word 2003 and all previous versions. 

1. Completely remove Office Connect
2. Open Word and:
    -Go to Tools | Security | Macro Security and it set it to Medium or Low
3. Click the OK button twice
4. Completely close Word (Make sure the Word is not running the processes tab in the ‘Task Manager’ if it does, click on WORD.EXE process and click on “End Process” button)

5. Re-install Office Connect
6. Word and Excel should now have the Salesforce Office Connect toolbar.

If you are still unable to see the toolbar move to Step D

Step D:
If you have tried all of the above suggestions, and are still running into trouble, please check to see if you have other plug-ins that may possibly interfering with Connect for Office plug-in, such as the Adobe Acrobat. If you have the Adobe Acrobat Writer plug-in installed (Note this refers to the WRITER plug-in and not the free Adobe Acrobat Reader), you will have to uninstall Acrobat and Office Edition. Afterward, reinstall Office Edition FIRST and then install Adobe Acrobat Writer. The two plug-ins should be installed and work concurrently.
You can check if this is the case by clicking on
Tools | Templates & Add-ins in Word.

However, if the problem persists, you will have to temporarily disable the Adobe Acrobat plug-in to use the Office Edition plug-in.

Click on Tools | Templates & Add-ins in Word.

Then deselect the pdfmaker.dot file and click OK. Restart Word if necessary and you should see the salesforce menu in the Word toolbar.

 
After you install the Salesforce Connect for Office
  • Open Word  / Excel
    • Click on the "Salesforce.com" tab  
    • Click on "Merge Field" (in Word) or “Reporting” (in Excel) and click on "Log in".
    • Type in your Salesforce username and password and click on Login
  • If you get an error that says you failed to login you are missing the API security token. To be able to login you would need an API Security Token that you can obtain from Salesforce org
    • You need to login to salesforce application
    • Go to Setup > Personal Setup > My Personal Information > Reset Security Token
    • Click on the gray "reset my security token"
    • Check email for new Security Token password
    • Double click on the security token to select it and then right click on it to copy it
        Example:
  • Go to Microsoft Word or Excel and click on Salesforce.com tab
  • Click on "Merge Field" and click on "Log in".
  • Enter the "password+new security token" in the password box
    • For example: if your password is 123456 and token is XXXxxx
 type in 12345XXXxxx
  • You can use the ctrl + v key combination on your keyboard to paste the token in the password box
  • Make sure you don't copy any blank space with the token
  • Click Login

 
 
 
 





promote demote