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Salesforce Classic Mobile App is slow or uncompleted syncing

Knowledge Article Number 000004293
Description

Issue:

iPhone or iPad running Salesforce Classic mobile app never completes interval sync or states that 'Sync is in progress'. Users are also told to NOT navigate away from the app during activation as this will stop the downloading of the local data to the device/app.

 

Cause:

Because of the device architecture of the iPhone iOS, most applications are not allowed to run "background" processes while the application is not 'In-Focus' (meaning visible to the user). This does apply to the Salesforce Classic mobile for iPhone application.

When Salesforce Classic mobile app is not in-focus, the activation or any interval sync process is halted and these syncs can back up further and further. This can also be especially noticeable during an activation or if major changes were made to the mobile configurations causing a large amount of schema /metadata and/or data to be pulled down to the device.

Resolution


Resolution:

These are the recommended setup steps to be taken locally on the users iPhone device.

  1. Go to iPhone > Settings > Classic (shows Salesforce Classic App icon)
  2. Set the ‘Keep Screen On’ setting to ON (prevents device from auto-locking w/o using touchscreen)
  3. Next time you see the warning, leave the app in focus and set it down
  4. Sync should complete and warning will clear
Other Suggestions: 
  • Be aware that the iOS does not run applications in the background. It is NOT a true multi-tenant OS (like BB or Android)
  • Work with your Salesforce System Admin to REDUCE the overall scope of your mobile dataset.
    • i.e. Don't use ALL RECORDS or limit date ranges.
    • Utilize MRU (Most Recent Items when possible and switch queries to NONE SEARCH ONLY.
    • Modify the excluded fields on the Mobile Configuration page

NOTE: removing the Last modified timestamp field along with any other field that is not necessary for mobile field users, and you can reduce the number of records that get flagged for updates.
 

These steps should allow the activation/sync processes to complete more readily. The user should also take steps to ensure that the SFDC mobile app remains uninterrupted during this action.





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