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Salesforce for Outlook events or tasks sync fails

Knowledge Article Number 000073330
Description Issue:

Salesforce for Outlook sync fails with an error message during the syncing of Events and Tasks

An unexpected error occurred when communicating with Salesforce. Review the appropriate log for details
 
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Trace and sync logs located in user folder would also show the following error:
 
ERROR [Event] ***********  Sync Engine  *********** 
Error  Exception code:UNKNOWN_EXCEPTION Sfdc.Server.SfdcServerException: syncapi.Command.NoAccessException: Entity is not readable

 
Resolution
Cause:

Affected users profile does not have the 'Edit' option enabled on the Event or Task object.

To confirm this, login to Salesforce and click on your Name and click on 'My Profile', click on 'User Details' and click on your Profile name

On the 'Profile detail page, scroll down to 'General User Permissions' section and see if the boxes for 'Events' and 'Tasks' are unchecked.

If the boxes are unchecked for either one of them the sync would fail during the synchronization of that object.

Troubleshooting steps:

This is not an issue that support can handle and it needs to be addressed by customer's System Administrator.

Simply, Edit the affected user profile and check the box for ‘Edit Events’ or 'Edit Tasks' under ‘General User Permission’ section.
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