Print this page

Force.com IDE installation

Knowledge Article Number 000130366
Description Pre-requisites for eclipse installation -
1) Operating system - Windows
2) Java SE Runtime Environment

Note: Please refer to the Force.com IDE Release Notes for the supported platforms
Resolution 1) Use the following link to find if you are using 32 bit or 64 bit Windows Operating System -
http://windows.microsoft.com/en-US/windows-vista/32-bit-and-64-bit-Windows-frequently-asked-questions

2) As per your Operating system properties - 32 bit or 64 bit, install the latest Java SE Runtime Environment here -
http://java.com/en/

3) To install Eclipse IDE, find the latest version and it's documentation here -
http://wiki.developerforce.com/page/Category:Force.com_IDE

Note: Make sure that the Eclipse IDE is compatible with the Java SE Runtime Environment you installed
 
4) After installing Eclipse, use the documentation you referred to install Eclipse IDE to also add Force.com IDE remote site and Force.com IDE plug-in

5) Once Eclipse restarts, select Window > Open Perspective > Other and select "Force.com", then click "OK."

To learn more about Force.com IDE, visit the following KB article on how to search/replace any expression in the entire org, search/replace any expression in a file, save/view your changes in salesforce.com, get latest snapshot of the files from salesforce.com and create backup files - "Getting Started with the Force.com IDE Project".




promote demote