Print this page

Salesforce for Outlook version 2.5 and above installer changes

Knowledge Article Number 000194302
Version 2.5 to 2.7.x of Salesforce for Outlook (SFO) uses a modified installation routine when compared to previous versions.  

It now focuses on the user instead of machine. It is installed Per User and not Per Machine anymore. It needs to be installed for each user on the computer as it installs into the current users %appdata% folder instead of the Program Files folder as with SFO versions 2.4.2 and older

There are quite a few benefits to this as it reduces potential permissions issues at install around file access in various folders.



C:\program files\\Salesforce for Outlook\



C:\Users\<username>\AppData\Roaming\\Salesforce for Outlook\


%appdata%\\Sales force for Outlook\

You can click on Start and type in the following to open this folder.
     %appdata%\\Salesforce for Outlook\

Because of this change Salesforce for Outlook  (2.5 and above ) will not upgrade from the previous version.  To install the v2.5 and above all older versions of SFO MUST be uninstalled from Control Panel | Programs and Features (Add or Remove Programs)
The installer also relocates the application log files to a new location:

C:\Users\<username>\AppData\Roaming\\Salesforce for Outlook\logs

The installer DOES NOT support IMAP and POP Outlook configurations.  After installation the Side Panel will reflect this with the warning: IMAP and POP3 email servers are not supported.


Also see - IMAP and POP3 email servers are not supported - Salesforce for Outlook

Salesforce for Outlook integrates with many Exchange solutions such as Hosted Exchange environments and Office 365
To find alternative Outlook integration point to meet your needs check the AppExchange here

Please refer to Salesforce for Outlook System Requirements 
as well as the Release notes for more information

promote demote