Loading

Mensajes de error frecuentes en el Cargador de datos

Fecha de publicación: Nov 4, 2025
Descripción

A continuación, mostramos una serie de errores frecuentes del Cargador de datos que se producen al utilizarlo para actualizar o insertar registros.

Solución

 

Error: La fila es mayor que el encabezado.

Causa: Hay datos en un campo sin un encabezado al que asignar.

Resolution: Revise todas las columnas y asegure que todas tienen un encabezado. Nota: revise varias columnas y filas de debajo del conjunto de datos, ya que las celdas con valores atípicos pueden contener datos inesperados.
 

 

Error: Credenciales insuficientes para acceder al Id. del objeto / credenciales insuficientes para acceder al Id. de referencia cruzada

Consulte  Configure Data Loader (Configurar Cargador de datos),para obtener más detalles.

Causa: el usuario que ha realizado la operación no tiene acceso a los registros o al objeto de referencia. Por ejemplo:

  • Se ha eliminado un registro al que hace referencia.
  • Nunca ha existido un registro al que hace referencia (por ejemplo, debido a un error en la escritura en el campo de Id.).
  • Existe un registro al que hace referencia, pero no se ha compartido con el propietario del registro que está insertando o actualizando.
  • Existe un registro al que hace referencia, pero no se ha compartido con el usuario que ejecuta la inserción o la actualización.
  • No tiene acceso al tipo de registro que se está asignando al registro.

Resolución: Reduzca el tamaño del lote del Cargador de datos a 1 para identificar la(s) fila(s) problemática(s). Compruebe todas las instancias de una columna que contiene los Id. de las filas afectadas pegando el Id. del registro relacionado en Salesforce en la dirección URL del navegador después del .com/ para abrirlo. Nota: Algunos Id. como los de tipo de registro u objetos tienen direcciones URL únicas. Para construir correctamente la dirección URL en estas circunstancias, primero abra un registro similar en la interfaz de usuario.


 

Error: Se ha encontrado un valor duplicado.

Causa: El usuario está intentando actualizar un campo único. Consulte Error 'Duplicate value found' when updating records using Data Loader (Error "Se ha encontrado un valor duplicado" al actualizar los registros con el Cargador de datos) para obtener más detalles.

Resolución: Reduzca el tamaño del lote a 1 para identificar las filas problemáticas del archivo. Abra el apartado para configurar el objeto de destino, revise todos los campos (columnas) que haya asignado en la configuración del Cargador de datos e identifique qué campo(s) tiene(n) seleccionado el atributo único. Utilice el Cargador de datos para hacer consultas en registros que contienen valores duplicados que se deben identificar y ajuste en su archivo los valores del campo afectado del registro duplicado.


 

Error: Valor de Id. del tipo de registro incorrecto.

Causa: El tipo de registro debe introducirse mediante su Id., no mediante el nombre.

Resolución: Revise los valores de su archivo para los tipos de registro e introduzca el Id. del tipo de registro correspondiente. Consulte Find the ID of a record type (Cómo localizar el Id. de un tipo de registro) para obtener más detalles. Revise la Guía del desarrollador de la API de SOAP sobre  RecordType.

 

Error: java.lang.OutOfMemoryError: espacio de heap de Java

Causa: Java ha agotado los recursos de memoria en su equipo local intentando ejecutar la operación de carga de datos.

Resolución: Consulte el artículo Error 'Java Heap Space' in Data Loader (Error "Espacio de heap de Java" en Cargador de datos) para obtener más detalles.


 

Error: Id. de propietario: Valor de Id. de tipo incorrecto:

Causas:

  • El propietario del registro debe introducirse mediante su Id., no mediante el nombre.
  • Este error también persiste en los campos de búsqueda de los registros relacionados en los que el valor del Id. indicado corresponde a otro objeto.


Resolución:


 

Error: System.Exception: Demasiadas consultas SOQL

Causa 1: El desencadenamiento del objeto está superando los límites regulados de apex.

Causa 2: El tamaño del lote se ha configurado a un número mayor. Intente reducir el tamaño del lote a 1 para que los registros se procesen uno por uno.

Resolución: Reducir el tamaño del lote puede contribuir a aliviar el problema, pero la solución a largo plazo debería consistir en trabajar con sus desarrolladores para configurar el registro de la depuración para identificar el código apex por revisar y modificar el código para procesar varios registros a la vez.


 

Error: No se ha procesado debido al error del lote: Batch no válido: Fallo al analizar el encabezado CSV

Causa: Este error solo se producirá si se ha activado la opción "Utilizar API masiva".

Resolución: Asegúrese de que al menos se ha asignado un campo o de que no se ha omitido el paso de asignación de campo. Para obtener más información, consulte Define Data Loader Field Mappings (Cómo definir las asignaciones de campos del Cargador de datos).


 

Error: La columna del nombre debe estar asignada cuando inserte registros solamente.

Causa: Se produce cuando el campo estándar de nombre (del objeto en cuestión) no se ha incluido en el archivo CSV.

Resolución: Incluya la columna de nombre en el archivo, especifique un nombre para cada registro y asígnelo al insertarlo.


 

Error: Formato de archivo CSV no válido. Seleccione otro archivo. Error al leer la fila #: el número de columnas de datos supera el número de columnas del encabezado.

Causa: La versión 34.0 del Cargador de datos introdujo la capacidad de usar archivos CSV delimitados por comas o tabuladores. Si un archivo delimitado con comas contiene caracteres de tabulador al menos en una celda, el Cargador de datos interpreta ese tabulador como una columna adicional.

Resolución: Utilice un editor de texto para modificar el archivo y rodee con comillas la celda en cuestión. Ejemplo: "123 Main St."


 

Error: Número no válido ("<Campo de nombre>: número no válido: <Valor de número>")

Causa: Este mensaje de error se muestra cuando la celda (archivo de importación) que apunta a un campo de número contiene comas como separadores de millares.

Resolución: Asegúrese de que los valores de los campos de número se escriben sin comas en el archivo de importación. En Excel resalte los datos numéricos que contengan comas, haga clic con el botón derecho para seleccionar las celdas con formato, elija la ficha del número, seleccione número como categoría y asegúrese de que la preferencia "Use 1000 Separator (,)" no está marcada.


 

Error: La colaboración de los miembros del grupo está en curso.

Este error se produce al actualizar la información del perfil del usuario y, si la regla de colaboración se ha configurado, el registro no se actualizará, ya que todas las reglas de colaboración se recalcularán cada vez que un registro único se actualice.

Resolución:

  • Desde Configuración, escriba "Defer Sharing Calculations" en el cuadro de búsqueda rápida y, a continuación, seleccione "Defer Sharing Calculations.
  • Haga clic en "Suspend" en la lista relacionada con la colaboración con cálculos de reglas.
  • Haga cambios a las reglas de colaboración, las funciones, los territorios o los grupos públicos que participan en las reglas de colaboración.
  • Para activar el cálculo de las reglas de colaboración, haga clic en "Resume" cuando haya acabado con los cambios.


 

Error: AccountAfterInsert: ejecución de AfterUpdate

Causa: El desencadenador está activo en el objeto de la cuenta que ha provocado el error de apex durante la operación de los datos.

Resolución: Reducir el tamaño del lote puede contribuir a reducir el problema, pero la solución a largo plazo debería ser que los desarrolladores configurasen un registro de depuración para identificar el código apex problemático y revisarlo y modificasen el código para procesar varios registros a la vez


 

Error: La operación no es válida para este tipo de usuario.

Causa: Este error se produce cuando el usuario que se está asignando está inactivo en esos momentos. 

Resolución: Compruebe de nuevo que el usuario esté asignado si está "Inactive". Si intenta modificar un registro que pertenece a un usuario inactivo, pida al administrador del sistema que active "Create Audit Fields".


Nota: los errores anteriores son los más frecuentes. Es posible que el error con el que se encuentre no esté en la lista.


Consulte también 
Error 'ID not specified in an update call' on update or upsert (Error "Id. no especificado en una llamada de actualización" al actualizar o insertar)

Unique Record IDs in Salesforce (Id. de registro únicos en Salesforce)
Error 'Failed to send request' or unable to login with Data Loader (Error "No se ha podido enviar solicitud" o no se puede iniciar sesión con el Cargador de datos) 
Error 'Use one of these records?' in Data Loader (Error "¿Desea utilizar uno de estos registros" en el Cargador de datos)

Número del artículo de conocimiento

000384437

 
Cargando
Salesforce Help | Article