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Messages d'erreur courants dans Data Loader

Date de publication: Nov 4, 2025
Description

Voici une liste des erreurs courantes de Data Loader que vous recevez lorsque vous utilisez Data Loader pour mettre à jour ou insérer des enregistrements.

Résolution

 

Erreur : La ligne est plus grande que l’en-tête

Cause : Un champ contient des données qui n’ont pas d’en-tête à mapper.

Résolution : Vérifiez chaque colonne et assurez-vous qu’un en-tête est présent. Remarque : Examinez plusieurs colonnes et lignes sous le jeu de données car les cellules hors norme peuvent contenir des données.
 

 

Erreur : Droits d’accès insuffisants à l’ID d'objet/droits d’accès insuffisants sur l’ID de référence croisée

Reportez-vous à l’article Configuration de Data Loader pour obtenir plus d’informations.

Cause : L’utilisateur qui effectue l’action n’a pas accès aux enregistrements ou à l’objet référencé. Exemple :

  • Un enregistrement que vous référencez est supprimé
  • Un enregistrement que vous référencez n’a jamais existé (par exemple, en raison d’une faute de frappe dans le champ ID d'enregistrement)
  • Un enregistrement que vous référencez existe mais n’est pas partagé avec le propriétaire d'enregistrement de l’enregistrement que vous insérez ou mettez à jour
  • Un enregistrement que vous référencez existe mais n’est pas partagé avec l’utilisateur qui exécute l’insertion ou la mise à jour
  • Vous n’avez pas accès au type d'enregistrement qui est attribué à l’enregistrement


Résolution : Réduisez la taille du lot Data Loader à 1 afin d’identifier la ou les lignes problématiques. Vérifiez chaque instance d’une colonne contenant un ID pour les lignes affectées en ouvrant l’enregistrement associé dans Salesforce et en collant l’ID après .com/ dans l’URL du navigateur. Remarque : Certains ID, tels que les types d'enregistrement ou les objets dans Lightning, ont des URL uniques. Dans ces circonstances, ouvrez d’abord un enregistrement similaire dans l’interface utilisateur pour créer l’URL appropriée.


 

Erreur : Valeur en double trouvée

Cause : L’utilisateur tente de mettre à jour un champ unique. Consultez Erreur « Valeur en double trouvée » lors de la mise à jour des enregistrements à l’aide de Data Loader pour obtenir plus d’informations.

Résolution : Réduisez la taille du lot à 1 pour identifier les lignes problématiques dans votre fichier. Ouvrez la section de configuration de l'objet cible, examinez chacun des champs (colonnes) que vous avez mappés dans votre opération Data Loader lors de la configuration et identifiez le ou les champs pour lesquels l’attribut unique est sélectionné. Utilisez Data Loader pour interroger les enregistrements contenant la valeur en double afin d’identifier et d’ajuster les valeurs de champ affectées de l’enregistrement en double dans votre fichier.


 

Erreur : Valeur ID d’un type d'enregistrement incorrect

Cause : Le type d'enregistrement doit être saisi avec l'ID, pas avec le nom.

Résolution : Vérifiez les valeurs de votre fichier pour les types d'enregistrement et saisissez l’ID de type d'enregistrement correspondant. Reportez-vous à l’article Trouver l’ID d’un type d'enregistrement pour obtenir plus d’informations. Consultez également le SOAP API Developer Guide pour RecordType.

 

Erreur : java.lang.OutOfMemoryError : Java heap space (Arrêt dû à java.lang.OutOfMemoryError : espace du tas Java)

Cause : Java a épuisé les ressources de mémoire sur votre ordinateur local en essayant d’effectuer l'opération de chargement des données.

Résolution : Reportez-vous à l’article Erreur « Java Heap Space » dans Data Loader pour obtenir plus d’informations.


 

Erreur : ID de propriétaire : Valeur ID de type incorrect :

Cause :

  • Le propriétaire d'enregistrement doit être saisi avec l’ID, pas avec le nom.
  • Cette erreur persiste également pour les champs de recherche dans les enregistrements associés où la valeur de l’ID indiqué est celle d’un objet différent.


Résolution :

  • Localisez les lignes affectées et remplacez les noms d’utilisateur par leur ID. Reportez-vous à l’article Localisation d’un ID d'utilisateur Salesforce pour plus d’informations.
  • Remplacez l’ID par l’ID de l’enregistrement correct de l’objet correct.


 

Erreur : System.Exception : Trop de requêtes SOQL

Cause 1 : Le déclenchement sur l’objet dépasse les limitations du gouverneur Apex.

Cause 2 : La taille du lot est définie sur un nombre supérieur. Essayez de réduire la taille du lot à 1 pour que les enregistrements soient traités un par un.

Résolution : La réduction de la taille des lots peut aider à atténuer le problème, mais la solution à long terme consiste à travailler avec vos développeurs pour configurer la consignation du débogage afin d’identifier l’Apex problématique à vérifier, ainsi qu’à traiter votre code en masse.

 

Erreur : Non traité suite à une erreur de lot : Lot non valide : Impossible d’analyser l’en-tête CSV

Cause : Cette erreur se produit uniquement si l’option « Utiliser l'API de transfert en masse » est activée.

Résolution : Assurez-vous qu’au moins un champ est mappé ou que l’étape de mappage de champ n’est pas ignorée. Pour obtenir plus d’informations, reportez-vous à l’article Définition des mappages de champ de Data Loader.


 

Erreur : La colonne Nom doit être mappée lors de l'insertion d'enregistrements uniquement

Cause : Cette erreur se produit lorsque le champ standard Nom (pour l’objet en question) n’est pas inclus dans le fichier CSV.

Résolution : Incluez la colonne Nom dans votre fichier et spécifiez un nom pour chaque enregistrement et mappez-le lors de l’insertion.


 

Erreur : Format du fichier CSV non valide. Sélectionnez un autre fichier. Erreur lors de la lecture de la ligne # : le nombre de colonnes de données dépasse le nombre de colonnes dans l’en-tête.

Cause : Data Loader 34.0 a introduit la possibilité d’utiliser des fichiers CSV séparés par des virgules ou des tabulations. Si un fichier délimité par des virgules contient des caractères de tabulation dans au moins une cellule, Data Loader lit cette tabulation comme une colonne supplémentaire.

Résolution : Utilisez un éditeur de texte pour modifier le fichier et mettez la cellule en question entre guillemets. Par exemple : « 123 Main St. »


 

Erreur : Champ numérique non valide (": invalid number: ")

Cause : Cette erreur est renvoyée lorsque la cellule (fichier d’importation) ciblant un champ numérique contient des virgules comme séparateurs de milliers.

Résolution : Vérifiez que les valeurs des champs numériques sont saisies sans virgule dans le fichier d’importation. Dans Excel, mettez en surbrillance les données numériques contenant des virgules et cliquez avec le bouton droit sur Format cellules... Choisissez l’onglet Nombre et sélectionnez Catégorie : Nombre et vérifiez que la préférence « Utiliser le séparateur de milliers (,) » n’est pas cochée.


 

Erreur : Opération d’appartenance à un groupe déjà en cours

Cette erreur se produit lorsque vous mettez à jour les informations de rôle de l'utilisateur. Si vous avez configuré une règle de partage, l’enregistrement ne sera pas mis à jour car toutes les règles de partage seront recalculées chaque fois qu’un seul enregistrement est mis à jour.

Résolution :

  • Dans Configuration, saisissez Reporter les calculs de partage dans la case Recherche rapide, puis sélectionnez Reporter les calculs de partage.
  • Dans la liste associée Calculs de règle de partage, cliquez sur Suspendre.
  • Apportez des modifications aux règles de partage, aux rôles, aux territoires, ou aux groupes publics qui participent à des règles de partage.
  • Pour activer le calcul de règle de partage, cliquez sur Reprendre une fois que vous avez terminé vos modifications.


 

Erreur : AccountAfterInsert: execution of AfterUpdate

Cause : Le déclencheur est activé sur l’objet Compte, ce qui entraîne l’échec d’Apex pendant votre opération de données.

Résolution : La réduction de la taille des lots peut aider à atténuer le problème, mais la solution à long terme consiste à travailler avec vos développeurs pour configurer la consignation du débogage afin d’identifier l’Apex problématique à vérifier, ainsi qu’à traiter votre code en masse


 

Erreur : Opération non valide pour ce type d'utilisateur

Cause : Cette erreur se produit lorsque l’utilisateur attribué est actuellement inactif. 

Résolution : Vérifiez si l’utilisateur attribué est « Inactif ». Si vous essayez de modifier un enregistrement appartenant à un utilisateur inactif, travaillez avec votre administrateur système pour activer la fonctionnalité « Créer des champs d'audit »

Remarque : Les erreurs ci-dessus sont les plus fréquentes. L'erreur que vous rencontrez peut ne pas être répertoriée dans la liste.



Numéro d’article de la base de connaissances

000384437

 
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