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Unable to customize 'my domain' and 'right frame URL'

Date de publication: May 8, 2026
Description

When administrators attempt to customize the Right Frame URL field under the 'Authentication Configuration' section of My Domain in a Salesforce org, the changes may not appear when accessing the org's My Domain login URL — even after saving successfully.

This usually occurs when the organization was created from a Trialforce Management Org (TMO) template, the branding from that organization gets carried across.

    Résolution

    Root Cause

    When a Salesforce org is provisioned from a Trialforce Management Org (TMO) template, the branding from the TMO are carried over to the child org. This means that even after saving a custom Right Frame URL in the child org's My Domain settings, the TMO-inherited branding may continue to display instead of the customized URL.

    Steps to Reproduce

     

    1. Navigate to My Domain:
      1. In Salesforce Classic: Setup | Domain Management | My Domain
      2. In Lightning Experience: Setup | Company Settings | My Domain
    2. Under the Authentication Configuration section, click Edit.
    3. In the Right Frame URL field, enter a custom URL (for example, `<REDACTED>).
    4. Click Save.
    5. Open the org's My Domain login URL (for example, yourorg.my.salesforce.com). The custom URL does not appear in the right frame.

    Resolution Steps

    If your org was created from a TMO template and you are experiencing this issue, raise a Salesforce Support case for assistance. 

    Ressources supplémentaires

    Salesforce Help: My Domain

    Numéro d’article de la base de connaissances

    000380545

     
    Chargement
    Salesforce Help | Article