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オムニチャネルで状況がオンラインに変更されたときのエラー「Disconnected from Omni-Channel」

公開日: May 15, 2026
説明

エージェントがオムニチャネルにログインできないエージェントがオムニチャネルウィジェットから状況を「オンライン」に変更すると常に、エラー「Disconnected from Omni-Channel.Log in again to receive work (オムニチャネルから切断されました。作業を受信するには再度ログインしてください)」が表示されます。


再現手順

  1. 組織にログインします
  2. Salesforce Classic にログインしている場合は、Lightning Experience に切り替えます
  3. アプリケーションランチャーをクリックし、オムニチャネルが有効にされているコンソール Lightning アプリケーションを選択します
  4. ブラウザ開発者ツールを開きます
  5. オムニチャネルウィジェットから自分自身をオンラインにしてみます。エラー「Disconnected from Omni-Channel.Log in again to receive work (オムニチャネルから切断されました。作業を受信するには再度ログインしてください)」が表示されることがあります。
  6. ブラウザ開発者ツールの Javascript コンソールログを確認します。コンソールにもエラーが表示されます。



考えられる原因:

  • オムニチャネルまたはチャットのログイン時間制限は最大 10 秒に設定されています。最近 10 秒以内に障害が発生した場合、「Disconnected from Omni-Channel.Log in again to receive work (オムニチャネルから切断されました。作業を受信するには再度ログインしてください)」などのメッセージが表示されます。
 
  • ユーザーに 200 を超えるチャットボタンが割り当てられている場合、ログイン時のタイムアウトによって、エラーメッセージが表示される可能性があります。
 
  • ユーザーが多数のオムニ対応キューまたはパブリックグループのメンバーである場合、10 秒後にオムニチャネル/チャットログイン障害が発生する可能性が高くなります
 
  • 自動グリーティングおよびクイックテキストはオムニチャネルログイン時間を延長させたり、遅延させたりすることがあります
 
  • 時間の 60% はボタンの読み込み (項目の代入によるカスタムグリーティングを含む) に費やされ、約 20% がグループまたはキューに費やされるため、ボタンを削減すると、大幅な改善が得られます。 
 
 
  • ストレージ制限を超えている場合。データ制限を超えている場合、新しい UserServicePresence レコードを生成できないため、オムニチャネルへのログインが失敗します。追加の詳細については、この記事を参照してください。
解決策

お客様がこれを回避するには、影響を受けるエージェントのグループメンバーシップ数 (このケースでの影響を受けるユーザーは 3000 を超えるグループと 600 を超えるボタンに属しています) を減らし、不要なチャットボタンを無効なチャット招待に変換するか、不要な自動グリーティングをチャットボタンから削除します。

ナレッジ記事番号

000381100

 
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