Loading

Proactive Alert Monitoring: Bulk API V2.0 Rows Limit

Data pubblicazione: May 27, 2024
Descrizione

 

The Signature Success plan's Proactive Monitoring product will monitor for, and alert you to, high consumption against this limit. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.


If you receive the following error message, your organization may temporarily be unable to perform bulk API row process updates (for up to 24 hours).
 

Full error message text:

  • QUERY_TIMEOUT


Examples of affected API callout scenarios from custom integrations:

  • Internal and external bulk data loads
  • Automated daily job processing
  • Background system processes

 

Causes

This system exception will be raised when bulk API row processing exceeds governor limitations for your Salesforce organization. These limits are determined by your current Salesforce edition (displayed in the title bar of your browser).
 

Possible bulk API row processing scenarios exceeding usage limitations:

  • Timeouts causing bulk jobs to retry multiple times
Risoluzione


Here are a few suggestions and resources that may help to resolve this error.
 

Timeouts causing bulk jobs to retry multiple times

  • Ensure triggers are optimized for bulk usage to limit the amount of timeouts. Disable any triggers associated with the user executing the upload.
 

Additional resources

 

AppExchange resources

 

Help and Developer resources

Numero articolo Knowledge

000382438

 
Caricamento
Salesforce Help | Article