Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

プロアクティブアラートモニタリング: SingleEmailMessage のコール数

公開日: Sep 1, 2023
説明
次のエラーメッセージのいずれかが表示された場合、組織で一時的に、選択されたインテグレーションパス経由でのメール送受信が行えない場合があります (最大 24 時間)。メールの制限に達した場合、それ以降のメールはすべて送信できなくなります。後続のメールを送信するには、GMT 時間の翌日の午前 0 時にメール制限がリセットされた後にメールを再送信する必要があります。

エラーメッセージ全文:
  • Apex/API Log Entry - SINGLE_EMAIL_LIMIT_EXCEEDED
  • Salesforce Interface - The daily limit for the org would be exceeded by this request.

メール送信が失敗した場合、以下の状況が考えられます:
  • Chatter 投稿
  • ケース更新の通知
  • ワークフローメールルール
  • バックグラウンドシステムの処理

注意: Salesforce のコアインフラストラクチャは、従業員間でのコミュニケーションを円滑にするように設定されており、マーケティングを目的としたものではありません。
 

原因

  • このシステム例外は、取引先責任者に対する SingleEmailMessage のコールが、ガバナ制限を超えた場合に表示されます。この制限の使用量は、ブラウザーのタイトルバーに表示されている Salesforce edition により決まります。
  • この事象は、(Apex や API によってトリガされた) メール送信の失敗により発生される可能性があります。

メール送信が失敗した場合、以下の状況が考えられます:
  • 不十分なコードで書かれた Apex バッチ送信
  • 不十分な API コールの設定や実行
  • 外部へのメール受信者、またはトランザクションの制限を超えた場合
  • 外部受信者の重複指定 (任意の送信用項目)
  • サイズ制限を超えた添付ファイル
解決策
以下は、このエラーの解決に役立つ可能性がある提案とリソースです。
 

不十分なコードで書かれた Apex バッチ送信

  • 内部ユーザーにメールを送信する場合、「setTargetObjectid」でユーザーの ID を指定しても、1 日あたりの送信制限数としてはカウントされません。
 

不十分な API コールの設定や実行

  • 大規模なデータ読み込み中は、トリガーの実行を無効にしてください。大規模データをアップロードすると、自動メール送信がトリガーされ、メール送信制限を短時間で超過してしまうことがあります。
     

外部へのメール受信者、またはトランザクションの制限を超えた場合

  • お使いの Salesforce 組織のエディションによって、1 度にメール送信できる宛先数と 1 日のメール送信数に、特定のガバナ制限が設けられています。いずれかの制限を超えると、エラーが発生し、メール送信を継続できなくなります。
 

外部受信者の重複指定 (任意の送信用項目)

  • 個々のアウトバウンド項目 (TO: CC: BCC:) のすべてのメールアドレスは、1 日のメール送信制限数としてカウントされます。重複したメールアドレスの指定も同様にカウントされます。


サイズ制限を超えた添付ファイル

 

追加のリソース

 

AppExchange リソース

 

Help and Developer リソース

ナレッジ記事番号

000382440

 
読み込み中
Salesforce Help | Article