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Proactive Alert Monitoring: Hourly Time Based Workflow Limit

Data pubblicazione: Jul 19, 2024
Descrizione

Workflow time triggers allow you to define rules that trigger time-based workflow actions off any Date or Date Time field on an object. These actions are subject to the hourly limit which, once exhausted, will cause subsequent executions to be deferred until the limit is reset. As a result, hitting the limit once may cause knock-on impact for some time afterwards.

The Signature Success plan’s Proactive Monitoring product will monitor for, and alert you to, high consumption against this limit. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.

If you receive the following error message, your organization may temporarily be unable to use workflow time triggers (for up to 1 hour).

Full error message text:

  • Hourly limit exceeded for processing workflow time triggers.

 

Causes

Below are some possible scenarios attributed to high limit usage:

  • Poorly coded Apex batch submissions
  • Poor API call setup and execution
  • Failure to consolidate workflow triggers within specific time-frames


 

Risoluzione

Here are a few suggestions and resources that may help to resolve high usage:
 

Poorly coded apex batch submissions

  • Any specific batch Apex classes triggering time-based workflows will count towards your organization's limit amount. Always review your Apex batch setup on a regular basis to prevent any usage restrictions.

 

Poor API call setup and execution

  • If an API call does not require a workflow to trigger the action, implement execution restrictions for all users using this method.

 

Failure to consolidate workflow triggers within specific time-frames

  • Trigger limits are reset hourly and users will encounter errors only when this hourly limit is reached. Organize daily jobs, spread out over time, to prevent hourly limits from being reached.

 

Additional resources

 

AppExchange resources

 

Help and Developer resources

Numero articolo Knowledge

000382445

 
Caricamento
Salesforce Help | Article