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Proactive Alert Monitoring: Streaming API Limit

Udgivelsesdato: Sep 1, 2023
Beskrivelse

The streaming API enables the streaming of events using push technology and provides a subscription mechanism for receiving those events in near real-time. These PushTopic events are subject to daily limits which, if exceeded, will prevent the delivery of subsequent events for up to 24 hours.

The Signature Success plan’s Proactive Monitoring product will monitor for, and alert you to, high consumption against this limit. This article outlines some scenarios to help you investigate should you receive an alert from Proactive Monitoring related to this limit. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.

If you receive the following error messages, your organization may temporarily be unable to send or receive API streaming data (for up to 24 hours).

Full error message text:

  • API streaming limit has been exceeded.

 

Causes

Below are some common scenarios that may cause high limit consumption:

  • Excessive record updates triggering notifications
  • Exceeding concurrent subscriber limitations
Løsning

Here are a few suggestions and resources that may help to resolve this error.
 

Excessive record updates triggering notifications

  • If you require multiple field updates using a streaming API query, schedule updates during non-business hours when smaller amount of users subscribed to the query are present.  


Exceeding concurrent subscriber limitations

  • The maximum concurrent subscriber count for streaming API daily limits varies across different Salesforce editions. Please reference: https://developer.salesforce.com/docs/atlas.en-us.api_streaming.meta/api_streaming/limits.htm 
 

Additional resources

AppExchange resources

 

Help and Developer resources

Vidensartikelnummer

000382446

 
Indlæser
Salesforce Help | Article