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Unable to select Salesforce Files to add images to Knowledge Articles in Lightning

Дата публикации: May 27, 2026
Описание
When you edit a Knowledge Article in Lightning Experience, it's only possible to select Files from user's local machines upon adding images to rich text area fields via the editor's Image button.


To select files from a User's local machine:

1. Open an existing Knowledge Article.
2. Click 'Edit as Draft' and proceed in clicking 'Edit as Draft' on the pop window.
3. Click 'Image' icon.
4. Opens a window to select files from user's local machine.
5. Select an image and click OK.
Решение

## Root Cause

Adding images to Knowledge Articles in Salesforce Lightning Experience is limited to files stored on the user's local machine. This is an intentional design change to prevent image availability issues. Salesforce Files stored within the org cannot be selected via the image editor at this time.

This is a design change that's intended to mitigate future occurrences of images being unavailable when added to Knowledge Articles in Lightning as outlined in the following Known Issue:
Images added to a Rich Text Area field on a Knowledge Article created in Lightning are visible only to the creator  

Consider creating and/or promoting an Idea on the IdeaExchange for visibility in the larger Trailblazer Community and potential consideration for including the ability to select Salesforce Files when adding an image to an article in Lightning with a future release.

Номер статьи базы знаний

000382479

 
Загрузка
Salesforce Help | Article