Loading

Salesforce Proactive Alert Monitoring: Async Apex Execution Limit Exceeded

Date de publication: Feb 26, 2025
Description

As Apex runs in a multitenant environment, Salesforce enforces limits to ensure that runaway Apex code or processes don’t monopolize shared resources. One such limit is applied to the maximum number of Asynchronous Apex method executions (batch Apex, future methods, Queueable Apex, and scheduled Apex) per ‌24-hour period. The limit is typically 250,000 or the number of user licenses in your org multiplied by 200, whichever is greater.

The Signature Success plan's Proactive Monitoring product will check for, and alert you to high consumption against this limit. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site, Designated Contacts and above can see your realtime metrics, alerts & more.  Note: You must be a Signature Success customer to view your metrics from this link.  

If you receive the following error message, your organization can temporarily be unable to process Async Apex requests (for up to 24 hours).

Full error message text:

  • AsyncApexExecutions Limit exceeded.

 

Causes

High-limit usage can often be caused by the following:

  • Inefficient Apex Classes
  • Poor API call setup and execution
  • Insufficient Licenses for the business need
Résolution

Here are some common practices & resources that may help to resolve this error. 


Inefficient Apex Classes

  • Ensure that any batch apex referencing @future or Queuable methods are bulkified.
  • Avoid @future methods and Queueable methods calling other @future and Queueable methods in a loop.
  • Ensure to keep a maximum batch size 2k for batch classes.


Poor API call setup and execution

  • Where possible, ensure API calls are using bulk features, for example SOAP envelope sizes of up to 200 in size or Composite Resources in the REST API.
  • If Apex triggers are being executed due to API calls, ensure the triggers are bulkified.


Insufficient Licenses for the business need:

  • As this limit can be determined by the number of User licenses (see above), adding more licenses can increase the limit provided the resulting calculation exceeds the standard daily limit of 250,000.
Numéro d’article de la base de connaissances

000382490

 
Chargement
Salesforce Help | Article