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Proactive Alert Monitoring: API Request Limit

Дата публикации: Aug 31, 2023
Описание

Salesforce applies limits to the total number of API Requests processed per day. REST API, SOAP API, Bulk API and Bulk API 2.0 calls all contribute to consumption of this limit which is typically defined by your Salesforce edition - outlined here.

The Signature Success plan's Proactive Monitoring product will monitor for, and alert you to, high consumption against this limit. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.

If you receive the following error message, your organization may be unable to process API calls for up to 24 hours.

Full error message text:

  • REQUEST_LIMIT_EXCEEDED

 

Causes

Some common causes for high limit usage, or limit exhaustion, are:

  • Cumulative record updates and changes
  • Using the REST API for upload/updates
  • Insufficient Licenses for the business need
Решение

Here are a few suggestions and resources that may help to resolve or mitigate high limit usage:
 

Cumulative record updates and changes

  • Processing API requests through cumulative changes can exhaust daily usage limits very quickly.  Changing your setup to incremental changes will separate requests over time and improve daily usage statistics.
 

Using REST API for upload/updates

  • Review these REST API calls for transition to the Bulk API, which should result in less API calls whilst achieving the same results.


Insufficient Licenses for the business need

  • The API request limit is typically calculated based on the no. of licenses you have for your Salesforce edition. Contact your AE to discuss the purchase of additional licenses, or leverage the Your Account App, to in turn increase your API Request Limit.
 

Additional resources


Help and Developer resources

Номер статьи базы знаний

000382493

 
Загрузка
Salesforce Help | Article