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Proactive Alert Monitoring: Hourly OData XDS Callouts Limit

Дата публикации: Jan 26, 2024
Описание


Salesforce Connect enables you to expose 3rd party services directly into the Salesforce application and surface the data as External Objects via OData Callouts. There is a limit to the number of OData XDS callouts conducted per hour, if you receive either of the following error messages, your organization may temporarily be unable to access external data sources through Salesforce Connect.
 

Full error message text:

  • Apex/API Log Entry - REQUEST_LIMIT_EXCEEDED
  • Salesforce Interface - The hour limit for the org would be exceeded by this request.


Examples of affected callouts from custom integrations:

  • Database to database communication
  • Referencing external components for VisualForce pages
  • SOAP/REST API setups
  • Accessing external encrypted data


The Signature Success plan’s Proactive Monitoring product will monitor for, and alert you to, high consumption against this limit. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.


Causes

Possible high limit consumption scenarios:

  • External, high-traffic objects set as related lists
  • Exceeding hourly limits set by organization edition
  • Improper permission settings
Решение


Here are a few suggestions and resources that may help to resolve this error.
 

External, high-traffic objects set as related lists

  • Use the 'High Data Volume' feature can cause features to be unavailable in your organization. Caching frequently accessed, infrequently changed data will cut down on usage counts.
 

Exceeding hourly limits set by organization edition

  • Depending on your qualified Salesforce organization edition, specific governor limits are in place for number of allowed callouts per hour and per day. When you exceed either of these limits, you will encounter one of the aforementioned errors and be unable to continue accessing external data sources.
 

Improper permission settings

  • Internal users without proper permissions enabled will be unable to access external data sources depending on their current status. Review our permission sets help documentation for further assistance in resolving user access issues.
 

Additional resources

 

AppExchange resources

 

Help and Developer resources

Номер статьи базы знаний

000382494

 
Загрузка
Salesforce Help | Article