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Proactive Alert Monitoring: Daily Mass-Mail Limits

Udgivelsesdato: Jan 26, 2024
Beskrivelse

Salesforce applies limits to the total number of Mass Mails that can be sent from your Salesforce environment per day. The limit for Mass Mails is typically 5,000. If you receive the following error message your organization may temporarily be unable to send or receive emails via your chosen integration path (for up to 24 hours).

Full error message text:

  • The daily limit for the org would be exceeded by this request.


Examples of affected email types from standard and custom integrations:

  • Internal and external email communication
  • Chatter posts
  • Case update notifications
  • Workflow email rules
  • Background system processes

The Signature Success plan’s Proactive Monitoring product will monitor for, and alert you to, high consumption against this limit. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.

Note: The Salesforce core infrastructure is set up to facilitate inter-office communication among employees and is not intended for marketing purposes.
 

Causes

Possible high limit consumption scenarios:

  • Poorly coded Apex batch submissions
  • Poor API call setup and execution
  • Exceeding external email recipient or transaction limits
Løsning

Here are a few suggestions and resources that may help to resolve this error.

Poorly coded Apex batch submissions

  • When you email internal users, specifying the user's ID in 'setTargetObjectid' will not count towards the daily send limit.


Poor API call setup and execution

  • Disable trigger execution during large inbound and outbound data loads. Uploading large volumes of data can cause automated email sends to trigger and can result with your limit being exhausted quickly.


Exceeding external email recipient or transaction limits

  • Depending on your qualified Salesforce organization edition, specific governor limits are in place for number of contacts per email and number of emails per day. When you exceed either of these limits, you will encounter the documented error and be unable to continue with your email sends.

 

Additional resources

AppExchange resources


Help and Developer resources

Vidensartikelnummer

000382496

 
Indlæser
Salesforce Help | Article