Loading

Proactive Alert Monitoring: Connection Pool Errors

Publiseringsdato: Jan 31, 2024
Beskrivelse

Connection Pools Errors can occur when there are no available connections to the database to send a request. A sustained volume of these errors can have a profound impact on your organization's performance. As such, if you receive the following error message(s), your organization may be experiencing performance issues and possible service disruptions.


Full error message text:

  • HTTP Status 500
  • Unable to find a connection to send a request

The Signature Success plan’s Proactive Monitoring product will monitor for, and alert you to, sustained volumes of these errors seen in your Salesforce environment. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.

Causes

Possible connection pool error scenarios:

  • Inefficient SOQL queries
  • Insufficiently configured reports, dashboards, and list views
Løsning

Here are a few suggestions and resources that may help to resolve this error.

Inefficient SOQL queries

 

Insufficiently configured reports, dashboards, and list views

    Knowledge-artikkelnummer

    000382569

     
    Laster
    Salesforce Help | Article