Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む
ナレッジ検索およびAgentforceの不具合に関するお知らせ続きを読む

プロアクティブアラートモニタリング: Bulk API コール数

公開日: Sep 1, 2023
説明
次のエラーメッセージが表示されている場合、組織で一時的に Bulk API のバッチ処理の更新ができない場合があります (最大 24 時間)。

エラーメッセージ全文:
  • QUERY_TIMEOUT

カスタムインテグレーションにより API コールアウトが起きる例:
  • 組織内外からの大規模な一括データロード
  • 自動化された日次ジョブの処理
  • バックグラウンド処理
 

原因

このシステム例外は Bulk API のバッジ処理が、組織のガバナ制限を超えたときに発生します。この制限の使用量は、ブラウザーのタイトルバーに表示されている Salesforce edition により決まります。

Bulk API コール数の制限超過について、以下の状況が考えられます:
  • 不十分なテスト
  • 正しくないバッチサイズ
  • 失敗したジョブへの Batch Retry ヘッダー
解決策
以下は、このエラーの解決に役立つ可能性がある提案とリソースです。
 

不十分なテスト

  • SandBox 環境でのテストは、大規模バッチのアップロードの最適化のためには重要です。Sandbox で発生している大規模ではないアップロードトリガーのタイムアウトを解決することで、本番環境で、再試行する回数を減らすことができます。
 

正しくないバッジサイズ

  • 送信前にバッチサイズが小さすぎないことを確認することで、すぐに Bulk 制限がかかることを防ぐことができます。
 

失敗したジョブへのBatch Retry ヘッダー

  • Batch Retry ヘッダー機能を使用する場合、事前に Sandbox 環境でテストをしてください。本番環境にデプロイする場合は、使用量制限が適用されます。
 

追加のリソース

 

AppExchange リソース

Help and Developer リソース

ナレッジ記事番号

000382576

 
読み込み中
Salesforce Help | Article