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Proactive Alert Monitoring: Bulk API Batch Limit

Дата публикации: Sep 1, 2023
Описание

The Bulk API is leveraged when a data operation (insert, update, upsert, delete) includes several thousand records. It is an Asynchronous process & subject to the standard API usage limits. Each HTTP request counts as one call for the purposes of calculating usage limits. Customers can submit up to 15,000 batches per rolling 24-hour period. Limit allocations for the bulk API are defined here.

The Signature Success plan's Proactive Monitoring product will monitor for, and alert you to, high consumption against this limit. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.

If you receive the following error message, your organization may temporarily be unable to process bulk API batch updates (for up to 24 hours).

Full error message text:

  • QUERY_TIMEOUT

 

Causes

Below are some common scenarios attributed to high limit usage:

  • Incorrect batch size
  • Batch retry headers on failing jobs
  • Insufficient testing
Решение


Here are a few suggestions and resources that may help to resolve high limit usage.

Insufficient testing

  • Sandbox testing is crucial for the optimization of large-sized batch uploads. Resolving any timeout issues occurring due to non-bulk upload triggers will limit the number of multiple retries in production.
 

Incorrect batch size

  • Verifying batch job sizes are not too small before sending will prevent expedited usage of your bulk limit.
 

Batch retry headers on failing jobs

  • If you decide to use the batch retry header feature, test your scenario in a sandbox environment. Usage restrictions will apply when deployed to production.
 

Additional resources

Help and Developer resources

Номер статьи базы знаний

000382576

 
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Salesforce Help | Article