Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

リストビュー作成時にエラーが表示される

公開日: Aug 21, 2024
説明

Salesforce Classic または Lightning Experience でリストビューを作成する際、以下のエラーのいずれかが発生することがあります。

Salesforce Classic でのエラー

「レコード保存時の入力エラー

該当するレコードの保存中に、カスタム入力エラーが発生しました。最初に発生した入力エラーは"この ビューの一意の名前 はすでに存在しているか、以前に使用されていました。別の名前を選択してください。"です。」

Lightning Experience でのエラー

「このリストビューを作成できませんでした。このページでエラーを確認してください。この リスト API 参照名はすでに存在します。別の名前を選択してください。」

原因

 既に存在する名前のリストビューを作成している可能性があります。その結果、既存のリストビューと API 名が一致し、エラーが発生します。

この動作は、[公開リストビューの管理] 権限を保有する別のユーザが編集権限を使用し、ログインユーザを含む他のユーザからリストビューを非表示にした場合に発生します。この際、非表示のリストビューと同じ名前のリストビューを作成すると、エラーとなります。

解決策

考慮事項

他のユーザによるリストビューの編集を制限することはできませんが、リストビューを作成する際には、以下のことを考慮することが推奨されます。

・ 別の API 名でリストビューを作成する
・ 一致する名前のリストビューへアクセス権を持つユーザを特定し、参照できるようリストビューの表示を[すべてのユーザに表示] に戻すか、リストビューの名前を変更します。  : 他のユーザとしてログインできるシステム管理者もこの操作を実行可能です。

上記の機能 (同じ API 名でリストビューを作成) の将来リリースでの機能追加を支持する場合は、IdeaExchange で  Scheduled Jobs List Views created by others should be visible to all users に投票可能です。

関連情報
データビューのカスタマイズ

ナレッジ記事番号

000383799

 
読み込み中
Salesforce Help | Article