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'Add to Salesforce’ Button in Outlook Integration and Gmail Integration Is Not Available

Дата публикации: Apr 5, 2024
Описание
Issue
When Outlook Integration or Gmail Integration loads in the respective email clients, some Users can't see the Add to Salesforce button.

Cause
This issue occurs when record types aren’t assigned to the User profile or the respective global actions properly.

Notes
  1. In Spring 18 or later, when you receive an email from an address that doesn’t match an email in a record in Salesforce, you can create a Contact, Lead, or Person Account (if Salesforce is set up with Person Accounts) directly from the Outlook Integration side panel. This change applies to both Lightning Experience and Salesforce Classic.
  2. The Add to Salesforce button is used to create a Contact or Lead for the selected emails that don't have a related record in Salesforce. Users can also see the Add to Salesforce button but when they click it, they can only see 'New Contact' and 'New Lead' where they’re allowed to create records for both objects from the side panel.
  3. In the Summer'22 release, for users with Einstein Activity Capture (EAC), we now only surface the records that are matched and associated by EAC in the Outlook/Gmail Integration add-in side panel. In the Compose/Reply email mode, we still do show the unmatched person along with the "Add to Salesforce" button in the side panel.
Решение

 

Make 'Add to Salesforce' button visible for Users in Outlook Integration or Gmail Integration


Note: Navigate to the affected User's profile and verify what record types are assigned to the Contacts and Leads objects. Review Assign Record Types to Profiles in the Original Profile User Interface for further information.

 

  1. Go to Global Actions
In Salesforce Classic: Setup | Create | Global Actions | Global Actions
In Lightning Experience: Gear icon | Setup | User Interface | Global Actions | Global Actions
 
  1. Click Edit next to the action that you want to change.
  2. Change the record type from Master to a record type that the User is assigned to and click Save.
  3. Now select Publisher Layouts under the same 'Global Actions' section from Setup and make sure the 'New Contact' and 'New Lead' actions are added to the Quick Action section of the Global Publisher Layout.
  4. Now open Outlook or Gmail and select an email to load Outlook Integration or Gmail Integration to verify the Add to Salesforce button is available on the email pane.
 

Note: If the customer is using a custom Email Application Publisher Layout for Outlook Integration or Gmail Integration, make sure the New Contact, or New Lead actions are added to the layout. Review Customize Email Application Action Menus and Assign Email Application Publisher Layouts to User Profiles.


See also
Create Global Quick Actions

Номер статьи базы знаний

000383891

 
Загрузка
Salesforce Help | Article