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Proactive Alert Monitoring: Dashboard Performance

Julkaisupäivä: Sep 1, 2023
Kuvaus

Dashboard refresh times can vary based on implementation and available resources. As an asynchronous process, refreshes will be placed in a queue & processed once resources become available (similar to asynchronous Apex). Long-running or poorly performing Dashboard Refreshes can make for a bad end-user experience and can also have a business impact if mission-critical Dashboards can't be refreshed as required.

The Signature Success plan’s Proactive Monitoring product will monitor for, and alert you to, sustained increases in dashboard runtimes. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.


Causes

Possible scenarios that may impact Dashboard Performance:

  • Poor Report Performance
  • Performance Degredation
  • Poor Visualforce Page Performance
Ratkaisu
Here are a few suggestions and resources that may help to resolve this error.


Poor Report Performance

Dashboard performance depends mainly on the performance of its source reports. If a dashboard is refreshing slowly, each report needs to be examined to find the slow running report. Please see the Improve Report Performance article.


Performance Degredation

Dashboard performance can be affected by a performance degradation. These are instance specific and can be checked here.


Poor Visualforce Page Performance

Dashboard components can include Visualforce pages that cause performance issues. These can be identified in the Dashboard Edit page and will say “Visualforce Page” as the chart type. Please see the Best Practices for Optimizing Visualforce Performance article.
Knowledge-artikkelin numero

000384139

 
Ladataan
Salesforce Help | Article