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Proactive Alert Monitoring: Asynchronous Callout Failures

Дата публикации: Sep 1, 2023
Описание

An Asynchronous Callout Failure occurs when an asynchronous callout initiated from your Salesforce org fails to successfully connect or return data from an external source.  

The Signature Success plan's Proactive Monitoring product will monitor for, and alert you to, high error volumes of this type. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.

If the following error text is included in the full text of an error message received, your organization may experience performance issues and possible service disruptions.

Full Error Message Text:

  • Unable to process request. System.CalloutException

 

Causes

Below are some common scenarios attributed to these errors:

  • Incorrect choice of API type (SOAP vs REST)
  • Pending transactions blocking any further callouts
  • Improperly configured remote site settings
  • External endpoints returning HTTP error codes
Решение


Here are a few suggestions and resources that may help to resolve this error.


    Incorrect choice of API type (SOAP versus Rest)

    • There are significant differences in usage, performance, and structure dependent upon your implementation of API callouts. Please reference our API usage and breakdown chart to determine the best course of action for your organization.


    Pending transactions blocking any further callouts

    • If you have uncommitted pending transactions queued, any further callout attempts will be blocked. Please refer to the following detailed breakdown if you are encountering this specific error scenario.


    Improperly configured remote site settings

    • Ensure all external endpoints are correctly configured via 'Remote Site Settings' within your Salesforce organization.  Please refer to our site settings configuration guide for best practices.


    External endpoints returning HTTP error codes

    • If you are attempting to connect to an external endpoint and you encounter HTTP error codes (404 not found, 500 internal server error), these failures will contribute to your failure percentage, and can potentially mask larger issues.


    Additional resources 

    Help and Developer resources

    Номер статьи базы знаний

    000384166

     
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    Salesforce Help | Article