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Proactive Alert Monitoring: Org Average Page Time (APT)

Data pubblicazione: Jan 26, 2024
Descrizione

Average Page Time (APT) is an aggregate metric across multiple transactions that tracks the average length of time requests spend in the app tier of the infrastructure. It does not take into account database time, network time, etc. As a result, significant increases in APT may result in your organization experiencing performance issues and/or service disruptions.

The Signature Success plan’s Proactive Monitoring product will create a model of your orgs APT use in order to monitor for, and alert you to, significant anomalies in your normal usage. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.
 

Causes

Possible APT performance impacting scenarios:

  • Inefficient or improperly configured Apex classes
  • Inefficient SOQL queries
  • Insufficiently configured reports, dashboards, and list views
  • Poor API call setup and usage
Risoluzione

Here are a few suggestions and resources for average page time performance and improvement.
 

Inefficient or improperly configured Apex classes

 

Inefficient SOQL queries

 

Insufficiently configured reports, dashboards, and list views

 

Poor API call setup and usage

  • Ensure you choose the right API for the job. Follow the Which API Do I Use? article for advice on choosing the appropriate API for your use case.
 

Additional Help and Developer resources

Numero articolo Knowledge

000384172

 
Caricamento
Salesforce Help | Article