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Proactive Alert Monitoring: Average Synchronous Callout Time

Publiceringsdatum: Jan 22, 2024
Beskrivning

Synchronous Callouts are leveraged to connect or return data from an external source. These callouts are typically executed in realtime and as such, in event these callouts take longer than expected, your organization may experience performance issues and possible service disruptions.

The Signature Success plan's Proactive Monitoring product will monitor for, and alert you to, high consumption against this metric. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.
 

Causes

Possible average callout failure scenarios:

  • Incorrect choice of API type (SOAP versus REST)
  • Endpoint unable to respond within allowed time frame
  • Read timeout exceptions when referencing external sources
Lösning

Here are some common practices & resources that may help to mitigate high runtimes.

    Incorrect choice of API type (SOAP versus Rest)

    • There are significant differences in usage, performance, and structure dependent upon your implementation of API callouts. Please reference our API usage and breakdown chart to determine the best course of action for your organization.
     

    Endpoint unable to respond within allowed time frame

    • Ensure referenced endpoints have sufficient bandwidth and processing power for handling bulk load requests from Salesforce.
     

    Read timeout exceptions when referencing external sources

    • When you set a maximum timeout frame, Salesforce will wait 120000 milliseconds for the result to return. If your process is failing, revise your exception time frames, and review any queries contributing to these failures.



    Additional resources

    Help and Developer resources

    Knowledge-artikelnummer

    000384183

     
    Laddar
    Salesforce Help | Article