Loading

Messaggi di errore più comuni in Data Loader

Data pubblicazione: Nov 4, 2025
Descrizione

Ecco un elenco degli errori più comuni in Data Loader che vengono visualizzati quando si utilizza Data Loader per aggiornare o inserire i record.

Risoluzione

 

Errore: La riga è più grande dell'intestazione

Causa: Un campo contiene dati che non hanno un'intestazione da mappare.

Risoluzione: Esaminare ogni colonna e assicurarsi che sia presente un'intestazione. Nota: Esaminare diverse colonne e righe sotto la serie di dati, poiché le celle esterne potrebbero contenere dati imprevisti.
 

 

Errore: Diritti di accesso insufficienti all'ID oggetto / diritti di accesso insufficienti per l'ID di riferimento incrociato

Consultare Configurare Data Loader, per maggiori informazioni.

Causa: L'utente che esegue l'azione non ha accesso ai record o all'oggetto a cui si fa riferimento. Ad esempio:

  • Un record a cui si fa riferimento è stato eliminato.
  • Un disco a cui si fa riferimento non è mai esistito (per esempio, a causa di un errore di battitura nel campo ID del record)
  • Un record a cui si fa riferimento esiste ma non è condiviso con il proprietario del record che si sta inserendo o aggiornando
  • Un record a cui si fa riferimento esiste ma non è condiviso con l'utente che sta eseguendo l'inserimento o l'aggiornamento
  • Non si dispone dell'accesso al tipo di record assegnato al record


Risoluzione: Ridurre le dimensioni del batch di Data Loader a 1 per individuare la riga o le righe problematiche. Controllare ciascuna istanza di una colonna contenente un ID per le righe interessate aprendo il relativo record in Salesforce incollando l'ID dopo .com/ nell'URL del browser. Nota: In Lightning alcuni ID come i tipi di record o gli oggetti hanno URL unici. In questi casi, aprire prima un record simile nell'interfaccia utente per costruire l'URL corretto.


 

Errore: Trovato valore duplicato

Causa: L'utente sta tentando di aggiornare un campo univoco. Per maggiori dettagli, vedere Errore 'Trovato valore duplicato' quando si aggiornano i record usando Data Loader.

Risoluzione: Ridurre le dimensioni del batch a 1 per individuare le righe problematiche nel file. Aprire la sezione di impostazione per l'oggetto di destinazione, rivedere ciascuno dei campi (colonne) mappati nell'operazione Data Loader nell'impostazione e individuare il campo o i campi con l'attributo univoco selezionato. Utilizzare Data Loader per cercare i record che contengono il valore duplicato e per individuare e rettificare i valori dei campi interessati dal record duplicato del file.


 

Errore: Tipo di record non corretto per il valore ID

Causa: Il tipo di record deve essere immesso con l'ID, non con il nome.

Risoluzione: Rivedere i valori del file cercando i tipi di record e inserire l'ID del tipo di record corrispondente. Per maggiori dettagli, vedere Trova l'ID di un tipo di record. Consultare anche la Guida per lo sviluppatore API SOAP per il RecordType.

 

Errore: java.lang.OutOfMemoryError: Java heap space

Causa: Java ha esaurito le risorse di memoria della macchina locale nel tentativo di eseguire l'operazione di caricamento dei dati.

Risoluzione: Per maggiori dettagli, vedere l'articolo Errore "Java Heap Space" in Data Loader.


 

Errore: ID proprietario: tipo non corretto per il valore ID:

Cause:

  • Occorre inserire il proprietario del record con l'ID, non con il nome.
  • Questo errore persiste anche per i campi di ricerca di record correlati in cui il valore dell'ID indicato si riferisce a un oggetto diverso.


Risoluzione:

  • Individuare le righe interessate e sostituire i nomi utente con i rispettivi ID. Per maggiori dettagli, vedere Individuare un ID utente Salesforce.
  • Sostituisci l'ID con l'ID del record corretto dell'oggetto corretto.


 

Errore: System.Exception: Un'eccessiva quantità di query SOQL

Causa 1: Il trigger dell'oggetto supera i limiti del governor Apex.

Causa 2: Le dimensioni del batch sono impostate su un numero più alto. Provare a ridurre le dimensioni del batch a 1 in modo che i record siano elaborati uno alla volta.

Risoluzione: Ridurre le dimensioni del batch può contribuire ad attenuare il problema, ma la soluzione a lungo termine è quella di lavorare con gli sviluppatori per Impostare la registrazione debug per individuare gli Apex problematici da rivedere ed Eseguire un'operazione "bulkify" sul codice.

 

Errore: Non elaborato a causa di un errore batch: Batch non valido: Analisi intestazione CSV non riuscita

Causa: Questo errore si verifica solo se "Utilizza API in blocco" è abilitato.

Risoluzione: Assicurarsi che almeno un campo sia mappato o che il passaggio di mappatura dei campi non venga saltato. Per ulteriori informazioni, vedere Definizione delle mappature dei campi di Data Loader.


 

Errore: È necessario che la colonna Nome sia mappata quando si inseriscono esclusivamente record

Causa: Questo succede quando il campo standard Nome (per l'oggetto in questione) non è incluso nel file csv.

Risoluzione: Includere la colonna Nome nel file, specificare un nome per ogni record e mapparlo in fase di inserimento.


 

Errore: Formato file CSV non valido. Selezionare un file diverso. Errore di lettura del numero di riga: il numero delle colonne dati supera il numero delle colonne intestazione.

Causa: Data Loader 34.0 ha introdotto la possibilità di utilizzare file CSV delimitati da virgole o tabulazioni. Se un file con valori delimitati da virgola contiene caratteri di tabulazione all'interno di almeno una cella, Data Loader legge quella tabulazione come una colonna aggiuntiva.

Risoluzione: Usare un editor di testo per modificare il file ed eseguire il wrapping della cella in questione tramite virgolette. Esempio: "123 Main St."


 

Errore: Numero non valido (": numero non valido: ")

Causa: Questo errore si verifica quando la cella (file d'importazione) che ha per destinazione un campo numerico contiene delle virgole come separatori delle migliaia.

Risoluzione: Assicurarsi che nel file di importazione i valori dei campi numerici vengano digitati senza virgole. In Excel, evidenziare i dati numerici contenenti virgole, fare clic con il tasto destro del mouse e selezionare Formato celle... scegliere la scheda Numero e selezionare Categoria: Numero e deselezionare la preferenza "Usa separatore delle migliaia (,)".


 

Errore: Operazione di appartenenza a gruppo già in corso

Questo errore si verifica quando si aggiornano le informazioni sul ruolo dell'utente e, se è stata impostata una regola di condivisione, il record non verrà aggiornato poiché tutte le regole di condivisione verranno ricalcolate ogni volta che viene aggiornato un singolo record.

Risoluzione:

  • Da Imposta, digitare Rinviare i calcoli di condivisione nella casella Ricerca veloce e selezionare Rinvia i calcoli di condivisione.
  • Nell'elenco correlato Calcoli della regola di condivisione, fare clic su Sospendi.
  • Apportare modifiche alle regole di condivisione, ai ruoli, ai territori o ai gruppi pubblici che partecipano alle regole di condivisione.
  • Per abilitare il calcolo delle regole di condivisione, fare clic su Riprendi una volta terminate le modifiche.


 

Errore: AccountAfterInsert: esecuzione di AfterUpdate

Causa: Il trigger è attivo sull'oggetto Account con conseguente errore di Apex durante l'operazione sui dati.

Risoluzione: Ridurre le dimensioni del batch può contribuire ad attenuare il problema, ma la soluzione a lungo termine è quella di lavorare con gli sviluppatori per impostare la registrazione debug per individuare gli Apex problematici da rivedere edeseguire un'operazione "bulkify" sul codice


 

Errore: Operazione non valida per questo tipo di utente

Causa: Questo errore si verifica quando l'utente assegnato è al momento inattivo. 

Risoluzione: Ricontrollare se l'utente assegnato è "Inattivo". Se si sta tentando di modificare un record di proprietà di un utente inattivo, valutare la possibilità di lavorare con il proprio amministratore di sistema per abilitare "Crea campi di controllo"

Nota: Gli errori sopra elencati sono quelli più comuni. L'errore che si verifica potrebbe non essere incluso nell'elenco.



Numero articolo Knowledge

000384437

 
Caricamento
Salesforce Help | Article