Loading

Mensagens de erro comuns no Data Loader

Data da publicação: Nov 4, 2025
Descrição

Aqui está uma lista de erros comuns do Data Loader que você receberá conforme o utiliza para atualizar ou inserir registros.

Resolução

 

Erro: A linha é maior do que o cabeçalho

Causa: Existem dados em um campo que não possui um cabeçalho para ser mapeado.

Resolução: Revise cada coluna e certifique-se de que um cabeçalho esteja presente. Nota: Revise várias colunas fora e abaixo do conjunto de dados, já que células fora do conjunto podem conter dados de forma inesperada.
 

 

Erro: Direitos de acesso insuficientes para ID de objeto/direitos de acesso insuficientes em ID de referência cruzada

Consulte Configurar o Data Loader para saber mais.

Causa: O usuário que executa a ação não tem acesso aos registros ou ao objeto referenciado. Por exemplo:

  • Um registro que você está referenciando foi excluído
  • Um registro que você está referenciando nunca existiu (por exemplo, devido a um erro de digitação no campo do ID do registro)
  • Um registro que você está referenciando existe, mas não é compartilhado com o proprietário do registro que você está inserindo ou atualizando
  • Um registro que você está referenciando existe, mas não é compartilhado com o usuário realizando a inserção ou a atualização
  • Você não tem acesso ao tipo de registro atribuído ao registro


Resolução: Reduza o tamanho do lote do Data Loader para 1 para identificar a(s) linha(s) problemática(s). Verifique cada instância de colunas contendo um ID para as linhas afetadas abrindo o registro relacionado no Salesforce colando o ID após o com/ no URL no navegador. Nota: Alguns IDs, como tipos de registro ou objetos no Lightning, possuem URLs exclusivos. Nessas circunstâncias, abra um registro semelhante na interface do usuário para criar o URL adequado.


 

Erro: Valor duplicado encontrado

Causa: O usuário está tentando atualizar um campo exclusivo. Consulte Erro "Valor duplicado encontrado" ao atualizar registros usando o Data Loader para obter mais detalhes.

Resolução: Reduza o tamanho do lote para 1 para identificar linhas problemáticas em seu arquivo. Abra a seção de configuração do objeto de destino, revise cada um dos campos (colunas) que você mapeou em sua operação do Data Loader na configuração e identifique quais campos possuem o atributo exclusivo selecionado. Use o Data Loader para consultar os registros que contenham o valor duplicado para identificar e ajustar os valores de campo afetados do registro duplicado em seu arquivo.


 

Erro: Valor de ID do tipo de registro incorreto

Causa: Os tipos de registro precisam ser inseridos com ID, não com nome.

Resolução: Revise os valores de seus arquivos para tipos de registro e insira o ID do tipo de registro correspondente. Consulte Encontre o ID de um tipo de registro para saber mais. Consulte também o Guia do desenvolvedor de API SOAP para RecordType.

 

Erro: java.lang.OutOfMemoryError: Java heap space

Causa: O Java exauriu os recursos de memória de sua máquina local tentando executar a operação de carregamento de dados.

Resolução: Consulte o arquivo Erro "Espaço do heap do Java" no Data Loader para obter mais detalhes.


 

Erro: ID proprietário: Valor do ID do tipo incorreto:

Causas:

  • Os proprietários de registro precisam ser inseridos com um ID, não com um nome.
  • Esse erro também persiste em campos de pesquisa de registros relacionados, em que o valor do ID indicado é para um objeto diferente.


Resolução:

  • Localize as linhas afetadas e substitua os nomes de usuários com os IDs. Consulte Localize um ID de usuário no Salesforce para mais detalhes.
  • Substitua o ID com o ID do registro correto do objeto correto.


 

Erro: System.Exception: Muitas consultas SOQL

Causa 1: O acionador no objeto está excedendo os limites reguladores do Apex.

Causa 2: O tamanho do lote tem um número definido muito alto. Tente reduzir o tamanho do lote para 1, de forma que os registros sejam processados um por um.

Resolução: Reduzir o tamanho do lote pode ajudar a aliviar o problema, mas a resolução de longo prazo seria trabalhar com seus desenvolvedores para Configurar registros de depuração a fim de identificar o Apex problemático com o intuito de revisar e encorpar seu código.

 

Erro: Não processado devido a um erro de lote: Lote inválido: Falha ao analisar o cabeçalho CSV

Causa: Este erro ocorrerá somente se a configuração "Usar API em massa" estiver habilitada.

Resolução: Certifique-se de que ao menos um campo esteja mapeado, ou que a etapa de mapeamento de campos não tenha sido pulada. Para mais informações, consulte Defina mapeamentos de campo no Data Loader.


 

Erro: A coluna Nome deve ser mapeada quando apenas ao inserir registros

Causa: Isso acontece quando o campo padrão Nome (do objeto em questão) não é incluído no arquivo .csv.

Resolução: Inclua a coluna Nome em seu arquivo e especifique um nome para cada registro, depois mapeie esses nomes durante a inserção.


 

Erro: Formato de arquivo CSV inválido. Selecione um arquivo diferente. Erro ao ler a linha #: o número de colunas de dados ultrapassa o número de colunas no cabeçalho.

Causa: O Data Loader 34.0 apresentou a capacidade de usar arquivos CSV delimitados por vírgulas ou tabulações. Se um arquivo delimitado por vírgula contém caracteres de tabulação dentro de ao menos uma célula, o Data Loader lê essa tabulação como uma coluna adicional.

Resolução: Use um editor de texto para editar o arquivo e envolver a célula dentro de aspas. Exemplo: "123 Main St."


 

Erro: Número inválido (": número inválido: ")

Causa: Este erro ocorre quando a célula (arquivo de importação) direcionada a um campo numérico contém vírgulas como separadores de milhar.

Resolução: Certifique-se de que os valores dos campos numéricos sejam digitados sem vírgulas no arquivo de importação. No Excel, destaque os dados numéricos que contêm vírgulas, clique com o botão direito e selecione Formatar células... Depois, escolha a tabulação de números, selecione Categoria: Número e desmarque a preferência "Usar separador (,) para 1000".


 

Erro: A operação de associação ao grupo já está em andamento

Este erro ocorre quando você está atualizando as informações de papel de um usuário. Se você tiver definido as regras de compartilhamento, o registro não será atualizado, já que todas as regras de compartilhamento serão recalculadas sempre que um único registro estiver sendo atualizado.

Resolução:

  • Em Configuração, insira Adiar cálculos de compartilhamento na caixa Busca rápida e selecione Adiar cálculos de compartilhamento.
  • Na lista relacionada de Cálculos de regras de compartilhamento, clique em Suspender.
  • Faça alterações nas regras de compartilhamento, nos papéis, nos territórios ou nos grupos públicos que participam das regras de compartilhamento.
  • Para habilitar o cálculo da regra de compartilhamento, clique em Retomar assim que tiver concluído suas alterações.


 

Erro: AccountAfterInsert: execução de AfterUpdate

Causa: O acionador está ativo no objeto de Conta, resultando na falha do Apex durante a operação de seus dados.

Resolução: Reduzir o tamanho do lote pode ajudar a aliviar o problema, mas a resolução de longo prazo seria trabalhar com seus desenvolvedores para Configurar registros de depuração a fim de identificar o Apex problemático com o intuito de revisar e encorpar seu código


 

Erro: Operação inválida para este tipo de usuário

Causa: Este erro ocorre quando o usuário atribuído está inativo no momento. 

Resolução: Verifique novamente se o usuário sendo atribuído está "inativo". Caso você esteja tentando editar um registro de propriedade de um usuário inativo, considere trabalhar com seu administrador de sistema para Habilitar "Criar campos de auditoria"

Nota: Os erros acima são os mais comuns. O erro encontrado pode não estar na lista.



Número do artigo do Knowledge

000384437

 
Carregando
Salesforce Help | Article