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Common error messages in Data Loader

Дата публикации: Nov 4, 2025
Описание

Here's a list of common Data Loader errors you'll receive as you use Data Loader to update or insert records.

Решение

Error: "Cannot invoke 'Object.toString()' because the return value of 'com.salesforce.dataloader.model.TableRow.get(Object)' is null" 

Cause: It is looking for an External Id field in the CSV mapping due to Perform updates with an external id field being checked  in Data Loader settings  

Resolution: Uncheck Perform updates with an external id field: in Data Loader settings  

 

Error: Row is larger than header

Cause: There is data in a field that does not have a header to map.

Resolution: Review each column and ensure a header is present. Note: Review several columns out and rows below the data set as outlier cells may contain data unexpectedly.
 

 

Error: Insufficient access rights to object ID / insufficient access rights on cross-reference id

Please review Configure Data Loader, for more.

Cause: User performing the action does not have access to the records or object being referenced. For example:

  • A record you are referencing is deleted
  • A record are referencing never existed (for example, due to a typo in the record Id field)
  • A record you are referencing exists but is not shared with the record owner of the record you are inserting or updating
  • A record you are referencing exists but is not shared with the user running the insert or update
  • You don't have access to the record type that is being assigned to the record


Resolution: Reduce the Data Loader batch size to 1 in order to identify the problematic row(s). Check each instance of a column containing an Id for the affected rows by opening up the related record in Salesforce by pasting in the Id after the .com/ in the browser's URL. Note: Some Ids such as record types or objects in Lightning have unique URLs. In these circumstances open a similar record in the user interface first to construct the proper URL.


 

Error: Duplicate value found

Cause: This is due to a duplicate within a 'Unique ID' field. The 'Unique ID' pertains to custom Fields where you have checked the box for "Unique ID". 



Resolution: If you are receiving the 'duplicate values found' error, you must remove the duplicates. Reduce batch size to 1 to identify problematic rows in your file. Open the setup section for the target object, review each of the the fields (columns) you have mapped in your Data Loader operation in setup and identify which field(s) have the unique attribute selected. Use Data Loader to query for records containing the duplicate value to identify and adjust the duplicate record's affected field values in your file.


 

Error: ID value of incorrect record type

Cause: Record type needs to be entered with ID, not name.

Resolution: Review your file's values for record types and input the corresponding record type Id. See Find the ID of a record type for more details. Also review the SOAP API Developer Guide for RecordType.

 

Error: java.lang.OutOfMemoryError: Java heap space

Cause: Java has exhausted memory resources on your local machine trying to perform the data load operation.

Resolution: See the article Error 'Java Heap Space' in Data Loader for more details.


 

Error: Owner ID: ID value of incorrect type:

Causes:

  • Record owner needs to be entered with ID, not name.
  • This error also persists for Lookup fields to related records where the value of the ID indicated is for a different object.


Resolution:

  • Locate affected rows and replace usernames with their Id. See Locate a Salesforce User ID for more details.
  • Replace the ID to the ID of the right record of the right object.


 

Error: System.Exception: Too many SOQL queries

Cause 1: Trigger on the object is exceeding the Apex governor limits.

Cause 2: Batch size is set to higher number. Try reducing the batch size to 1 so that records are processed one by one.

Resolution: Reducing batch size may help to alleviate the issue but the long term fix would be to work with your developers to Set Up Debug Logging to identify problematic Apex to review and Bulkify your code.

 

Error: Not processed due to batch error: Invalid Batch : Failed to parse CSV header

Cause: This error will only occur if the "Use Bulk API" is enabled.

Resolution: Make sure that at least one field is mapped or the field mapping step is not skipped. For more information, see Define Data Loader Field Mappings.


 

Error: Name column must be mapped when solely inserting records

Cause: This happens when the Name standard field (for the object in question) is not included in the csv. file.

Resolution: Include the Name column in your file and specify a name for each record and map it on insert.


 

Error: Invalid CSV file format. Please select a different file. Error reading row #: the number of data columns exceeds the number of columns in the header.

Cause: Data Loader 34.0 introduced the ability to use comma or tab delimited CSV files. If a comma delimited file contains tab characters within at least one cell, Data Loader reads that tab as an additional column.

Resolution: Use a text editor to edit the file and wrap the cell in question in quotation marks. Example: "123 Main St."


 

Error: Invalid Number ("<Field Name>: invalid number: <Number Value>")

Cause: This error is returned when the cell (import file) targeting a number field contains commas as thousands separators.

Resolution: Make sure that number field values are typed with no commas in the import file. In Excel highlight the number data containing commas, right click select Format Cells... choose the number tab and select Category: Number and ensure "Use 1000 Separator (,)" preference is unchecked.


 

Error: Group membership operation already in progress

This error occurs when you are updating user's role information and if you have sharing rule set up, record will not get updated as all sharing rules will be recalculated every time a single record is getting updated.

Resolution:

  • From Setup, enter Defer Sharing Calculations in the Quick Find box, then select Defer Sharing Calculations.
  • In the Sharing Rule Calculations related list, click Suspend.
  • Make changes to sharing rules, roles, territories, or public groups participating in sharing rules.
  • To enable sharing rule calculation, click Resume once you done with your changes.


 

Error: AccountAfterInsert: execution of AfterUpdate

Cause: Trigger is active on the Account object resulting in Apex failing during your data operation.

Resolution: Reducing batch size may help to alleviate the issue but the long term fix would be to work with your developers to Set Up Debug Logging to identify problematic Apex to review and Bulkify your code


 

Error: Operation not valid for this user type

Cause: This error occurs when the User being assigned is currently inactive. 

Resolution: Double check the User being Assigned if they're "Inactive". If you are attempting to edit a record owned by an inactive user, consider working with your System Administrator to Enable 'Create Audit Fields'

Note: The above errors are the common ones. The error you encounter might not be in the list.



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