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Salesforce for Outlook ウィザードでフォルダがグレー表示される

公開日: Mar 4, 2024
説明

重要: Winter ‘19 以降、Salesforce for Outlook を設定したことがなかい場合、あるいはユーザが定期的に使用していない場合は、このサービスは使用できなくなります。

また、Microsoft や Salesforce による Microsoft Outlook 2007 のサポートはすでに終了しています。詳細は、「
Office 2007 のサポート終了」を参照してください。

問題

ユーザが Salesforce For Outlook (SFO - 任意のバージョン) をインストールし、各自のユーザ名とパスワードを入力してウィザードを開始し、[Salesforce for Outlook の設定] ウィンドウの次の画面で、Outlook のフォルダを選択するようウィザードに指示されたときに、Outlook が開いていても、取引先責任者、行動、ToDo の各フォルダがグレー表示される。 

 
 
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グレー表示されているフォルダや、表示されていないフォルダに注意します。この表示の問題がこの記事に関連している可能性があるためです。 
 

原因

この問題は、次のいずれか、またはすべてに起因する可能性があります。

  1. Microsoft Outlook が実行されていない
  2. Microsoft Outlook または SFO がシステム管理者として実行されている
  3. Outlook データファイル (.OST) が存在しない、またはデータファイルが破損している
  4. Outlook プロファイルが破損している、または問題がある
  5. Office Library ファイルが重複し、Outlook の異なるバージョンを参照している
  6. レジストリの Redemption キーが破損している
  7. Redemption キーのインスタンス
  8. ユーザが Windows 7 を開いている場合、[ユーザー アカウント制御] が「高」に設定されている (「Windows Vista、Windows 7、Windows 8 および Windows 10 の UAC (ユーザーアカウント制御) を無効にする」を参照)
  9. Office の異なるバージョンがインストールされ、古いほうのバージョンが最近インストールまたは変更された
  10. 破損した MsMAPI.dll または Mapi32.dll (インストールしている Office によって異なります)
  11. Microsoft Office のインストールに問題または破損があり、UI とレジストリで異なるビット数が表示される
  12. Powershell またはグループポリシーのアクセスのブロックの問題の一部については、基本的な Powershell コマンドが正常に実行できるか Powershell コマンドをテストして確認します。詳細は、「SFO および Outlook の接続性に関する Powershell テスト」を参照してください。 

例 1: ユーザに Outlook 2010Office 20013 がある場合、Outlook 2013 がインストールされた後に Office 2010 が更新/変更/インストールされた。
 
例 2: Office Business Edition (Outlook 2010 または 2016 を含む) と Office Home Edition (Outlook を含まない) があり、Office Business Edition の導入後に Home Edition が更新/変更/インストールされた。
 
Windows 7、8 および 10 オペレーティングシステムでは、[プログラムと機能] ウィンドウで日付を確認できます。
 
 
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解決策

1 - Microsoft Outlook が実行されていない

Outlook を開きます。開いている場合は、一旦閉じて数秒間待機してからもう一度開きます。

 

2 - Microsoft Outlook または SFO がシステム管理者として実行されている

まず SFO と Outlook を終了してから、SFO を右クリックし、[プロパティ][互換性] タブを順にクリックして、チェックボックスが 1 つもオンになっていないことを確認します。

Outlook でも同じ手順を実行します。この場合も、Outlook が閉じていることを確認してから、キーボードの SHIFT キーを押したまま、デスクトップまたはタスクバーの Outlook アイコンを右クリックします。次に、[プロパティ][互換性] タブを順にクリックして、チェックボックスが 1 つもオンになっていないことを確認します。
 
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3 - Outlook データファイル (.OST) が存在しない、またはデータファイルが破損している

Outlook が Exchange キャッシュモードで実行されていることを確認します。すでにキャッシュモードで実行され、マシンにデータファイル (.OST ファイル) が存在する場合は、そのファイルを作成し直す必要のある場合があります。

記事番号 000188551 を参照してください。

時として、この問題が Outlook プロファイルの重複や破損に起因していることがあります。そのために SFO が混乱し、適切なプロファイルに接続できなくなります。

 

4 - Outlook プロファイルが破損している、または問題がある

既存の Outlook プロファイルを変更する必要はありません。問題をテストし、Outlook プロファイルに関連していないことを確認するために、Outlook でメールのないプロファイルを新規作成し、ウィザードを実行して、フォルダが適切に表示されるかどうかを確認します。

このテストを行うには、次の手順に従います。

 
  1. Outlook を閉じてから、[コントロール パネル]メールアイコンをダブルクリックします (上部の [検索] ボックスも使用できます)。
  2. [メール設定] ポップアップボックスで、[プロファイルの表示...] をクリックします。
  3. [Microsoft Outlook の起動時に使用するプロファイル:] ラジオボタンが [使用するプロファイルを選択する] に設定されていることを確認します。
  4.  [追加...] をクリックして、[新しいプロファイル] ウィンドウに「Test-profile」などの名前を入力し、[OK] をクリックします。
  5. 新しいアカウントの追加ウィザードが自動的に起動したら[キャンセル] をクリックします。
  6. 以下のポップアップボックスが表示されます。
  7. [OK] をクリックし、もう一度 [OK] をクリックして [メール] ウィンドウを閉じます。
 

 

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Outlook を開いて新しいプロファイルを選択してから、SFO を実行し、ウィザードを再試行して、フォルダが依然としてグレー表示されるかどうかを確認します。グレー表示にならず、フォルダを表示して選択できる場合は、ユーザの既存の Outlook プロファイルが破損しているため、ユーザまたは IT チームに作成し直してもらう必要があります。

 

重要: 貴社の (お客様の) IT部門に連絡して、新しい Outlook プロファイルを作成してもらうこともできます。


 

5 - Office Library ファイルが重複し、Outlook の異なるバージョンを参照している

注意:
レジストリの編集内容に問題があると、システムが正常に動作しなくなる場合があります。 特に、誤ったキーを削除することにより、Windows が起動しなくなることもありますので 十分に注意して実施してください。


レジストリに重複しているキーがないかチェックする必要があります。

レジストリエディタを開くには、キーボードの Windows (キー) + R キーの組み合わせを押して (下図を参照)、「REGEDIT」と入力し、Enter を押します。

キーボードの Windows キー
 
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レジストリエディタで、

HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046} に移動します。


どのキーもコンピュータにインストールされている MS Outlook のバージョンを参照するため、このキーの下にキーが 1 つの表示されます。コンピュータにインストールされた Microsoft Outlook のバージョンに対応するキー
 
Office 2003 は 9.2、Office 2007 は 9.3、Office 2010 は 9.4、Office 2013 は 9.5、Office 2016 は 9.6
 
 
たとえば、コンピュータに Office 2007 がある場合に、Outlook (または Office) 2010 をインストールまたはアップグレードすると、ここに 2 つ目のキーが作成されます。その後気が変わって、Office 2010 バージョンをアンインストールし、Outlook 2007 を使い続けたとします。時として、対応するキーがアンインストーラで削除されないことがあります。そうした場合には、Outlook 2007 のキーと 2010 のキーの 2 つが存在します。そのため、9.3 キーを保持し、9.4 キーを削除する必要があります。
 
このエントリが 1 つのみの場合は、次のステップに進みます。** レジストリエディタはまだ閉じないでください。

 
例: ユーザは Outlook 2007 のみをインストールしているため、9.3 キーが表示される。

 
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例: エントリが正しくない場合。ユーザは Outlook 2010 を使用しているが、エントリが 2 つある。9.3 キー (Outlook 2007 を参照) を右クリックして、[削除] をクリックする必要があります。
 
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6 - レジストリの Redemption キーが破損している

注意:
レジストリの編集内容に問題があると、システムが正常に動作しなくなる場合があります。 特に、誤ったキーを削除することにより、Windows が起動しなくなることもありますので 十分に注意して実施してください。


続いて、次のキーもレジストリから削除して、レジストリを閉じます (Redemption エントリが複数ある場合もありますが、すべて削除します)。保存する必要はありません。

 

HKEY_CURRENT_USER\Software\Redemption HKEY_CURRENT_USER\Software\Redemption * HKEY_CURRENT_USER\Software\Redemption * * HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Redemption
 
 

7- Redemption キーのインスタンス

古い SFO のインストールでは、Redemption のバージョンを示す Redemption キーがレジストリに作成され、挿入されます。 SFO v3.0 および新しいバージョンではこのキーは必要なくなり、削除する必要があります。

HKEY_CLASSES_ROOT\TypeLib\ に移動し、このキー {2D5E2D34-BED5-4B9F-9793-A31E26E6806E} を右クリックして [削除] をクリックします。

 

8 - ユーザが Windows 7 を開いている場合、[ユーザー アカウント制御] が「高」に設定されている (KB 000019209 を参照)

ステップ 8  (Windows 7 の UAC ([ユーザー アカウント制御]) が [通知しない] に設定されている場合は (KB 000019209)、問題を修正せずにステップ 9 に進みます。

 

9 - Office の異なるバージョンがインストールされ、古いほうのバージョンが最近インストールまたは変更された

A - Outlook が閉じていることを確認します。
 
B - Salesforce for Outlook と次のアプリケーションをアンインストールします。
 
       - Visual Studio® 2010 Tools for Office Runtime (x64) (VSTO)
 
Outlook 2010 がある場合:
      - Outlook 2010 ユーザ: 「Office 2010 プライマリ相互運用機能アセンブリ」をアンインストールします。 
 
Outlook 2007 がある場合:
      - Outlook 2007 ユーザ: 「Office 2007 プライマリ相互運用機能アセンブリ」をアンインストールします。
 
Outlook 2013 以降の場合は、Office のインストールに PIA が .NET Programmability のオプションとして付属します。SFO のインストールについては、

記事番号 000193384 を参照してください。ユーザに Office 2013

Windows 7/8/10 がある場合: [コントロール パネル] \ [すべてのコントロール パネル項目] \ [プログラムと機能]
 
* 注意
Windows や Outlook のバージョンによって UI が若干異なることがあります。
 
C - Office のインストールの修復を実行します。必ず Microsoft Outlook を含むバージョンを修復します。[コントロール パネル] のプログラムのリストから、修復する Office のバージョンを選択して、[変更] をクリックします。[修復] が選択されていることを確認してプロセスを終了します。
** 注意
Office 2013 を使用している場合は、[実行] をクリックします。Office 365 の場合は、オンライン修復を実行する必要があります。クイック修復は使用しないでください。
 
D - 修復プロセスが終了するまで待ち、コンピュータを再起動します。このステップを省略しないでください。
E - 再起動したら、次に移動します。
 
          Windows 7、8、8.1、10 のユーザ:   
%AppData%\salesforce.com\Salesforce for Outlook\ に移動して、すべて削除します。
 
 

10- 破損した MsMAPI.dll または Mapi32.dll


1-まず、SFO を含むすべてのプログラムを閉じます。 SFO を終了するには、システムトレイのアイコンを右クリックし、[終了] をクリックします。

2- コマンドプロンプトを管理者として実行します。もしくは別のローカル管理者の資格情報を使用します。
3-  以下のコマンドを実行し、Enter を押します。 「SUCCESS: The file now owned by user "ユーザ名"」というメッセージが表示されます。
Takeown /F c:\windows\system32\mapi32.dll​

​​4- ​次のコマンドを使用して mapi32.dll ファイルを mapi32.dll.old の名前に変更します。
 
Rename c:\windows\system32\mapi32.dll   mapi32.dll.old


5- mapi32.* の DIR コマンド (コマンド: Dir mapi32.*) を実行すると、その名前と拡張子を持つすべてのファイルが一覧表示され、ファイル拡張子が変更されているかどうかを確認することができます。 以下のコマンドの例とスクリーンショットを確認してください。C:\windows\system32 フォルダに移動して Mapi32 を検索し、ファイルの名前が変更されていることを確認してください。 拡張子は表示する必要があります。そうでないと.dll や .old が表示されず、ファイル名のみが表示されます。

6- 最後にファイルの名前が変更されたら、Fixmapi.exe コマンドを実行して mapi32.dll の新しいインスタンスを作成します。
7- Outlook を起動してから SFO を実行します。
8- 問題の再現を試みます。

これらのコマンドの順を追った例を確認してください。
 
C:\windows\system32>takeown /F c:\windows\system32\mapi32.dll                      (mapi32.dll ファイルの所有権を取得する - この例ではこの記事の作成者のユーザー名が表示されていますが、代わりにドメイン\ユーザ名が表示されます)

SUCCESS: The file (or folder): "c:\windows\system32\mapi32.dll" now owned by user "SFDC\hgharadaghi"
.

C:\windows\system32>rename c:\windows\system32\mapi32.dll mapi32.dll.old                            (mapi32.dll から mapi32.dll.old に名前を変更します)

C:\windows\system32>Dir mapi32.*                                      (ファイル名が mapi32 で任意の拡張子を持つすべてのファイルを一覧表示します )
 Volume in drive C is OSDisk
 Volume Serial Number is 940A-997E

 Directory of C:\windows\system32

10/28/2014  07:36 PM           102,912 mapi32.dll.old
               1 File(s)        102,912 bytes
               0 Dir(s)  356,389,900,288 bytes free

C:\windows\system32>fixmapi               (mapi32.dll ファイルの新しいインスタンスを作成します)

C:\windows\system32>dir mapi32.*      (mapi32.dll の新しいインスタンスが作成されたことを確認します)
 Volume in drive C is OSDisk
 Volume Serial Number is 940A-997E

 Directory of C:\windows\system32

10/28/2014  07:36 PM           102,912 mapi32.dll
10/28/2014  07:36 PM           102,912 mapi32.dll.old
               2 File(s)        205,824 bytes
               0 Dir(s)  356,389,793,792 bytes free

C:\windows\system32>
User-added image
 

 記事 000167727 を参照して SFO をインストールします。

この時点で問題を再現してみます。
 

11. Microsoft Office のインストールに問題または破損があり、UI とレジストリで異なるビット数が表示される

特定の Office のインストールでは、Outlook がレジストリと UI で 2 つの異なるビット数でインストールされます。インストールが正しく完了したことを確認するには、Outlook のビット数を UI で確認して、レジストリ内のビット数と比較します。値が一致しない場合は、社内の IT チームに連絡して問題を解決してください。問題が解決しない場合は、IT チームから Microsoft に問い合わせを行う場合があります。

Outlook を開いて、左側のメニューで [ファイル] | [Office アカウント] をクリックして、[Outlook のバージョン情報] をクリックします。
詳細は、ナレッジ記事
「Salesforce for Outlook - インストールされている Salesforce for Outlook (SFO) のバージョンを確認する」 を参照してください。

キーボードの Windows + R キーを押して、実行ウィンドウを開いて「Regedit」と入力し、Enter キーを押すと、Windows のレジストリが開きます。HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office に移動します。インストールされているOfficeのバージョンによって番号が異なります。詳細は、次の表を参照してください。
 

Office バージョン 

Registry キー番号  xx.0

2016 および O365

16.0

2013

15.0

2010

14.0

2007

12.0


たとえば、Office 2016 がインストールされている場合、HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Outlook を確認します。 
Outlook をクリックして、右側に表示されるビット数を確認します。
注意*
x86 32bitx6464bit です。この値は、Outlook の画面で [Outlook のバージョン情報] をクリックしたときに表示される値と一致する必要があります。


関連イメージのリンク

15.0 または 14.0 のフォルダがある場合は、社内の IT サポートに Outlook サブフォルダ の削除を依頼します。フォルダを開いて、その中に Outlook フォルダが存在するか確認します。存在する場合は、他のバージョンの Office がインストールされているか確認します。15.0 および 14.0 に Outlook が含まれる場合は、アンインストールおよび余分なキーの削除を行い、Outlook を含む他のインスタンスの Office もアンインストールする必要があります。たとえば、Office 365 と Office 2013 または Outlook 2013 をインストールすることはできません。SFO が機能するには、マシン上の Office のインスタンスが 1 つのみである必要があります。

つまり、HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\xx.0\OutlookOutlook | [ファイル] |Office アカウント | [Outlook のバージョン情報] のビット数を比較して、SFO が機能するには数字が一致する必要があるので、一致しない場合はまずその問題を解決してから、そのマシンに SFO をインストールするためのサポートを受けることができます。

メモ:
機能が進化した次世代製品、Outlook インテグレーションと Lightning Sync もご用意しています。製品の詳細と設定方法については、
Outlook インテグレーションのトレイルを参照してください。

 
 
ナレッジ記事番号

000384943

 
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Salesforce Help | Article