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Folders, Next button, or Save button may be grayed out in the Salesforce for Outlook wizard

Publiseringsdato: Mar 4, 2024
Beskrivelse

IMPORTANT: Starting in Winter ‘19, service is no longer available if you have never set up Salesforce for Outlook or your users aren’t regularly working with it.

Also, Microsoft Outlook 2007 is no longer supported by Microsoft or Salesforce. See 'Office 2007 has reached end of extended support' in Microsoft support site.

 

Issue

When you install Salesforce for Outlook, the wizard will pop up and ask you to enter your username and password. After you enter your credentials, on the next screen on the Salesforce or Outlook Settings window, where wizard prompts you to select a folder in Outlook (if you have the Sync functionality enabled) you may find that the Contacts, Calendar, or Task folders as well as the Next button (if you are syncing) or Save button (if sync is turned off) is grayed out, despite your Outlook being open.

 
Please pay attention to the folder icon that is grayed out or missing since this could be related to the Sync and data set configuration for 'Lightning Sync' and 'Salesforce for Outlook' article.
 

Cause

This issue can be caused by one or all of the following:

 

1. Microsoft Outlook is not running.
2. Microsoft Outlook or SFO are running as Administrator.
3. Missing Outlook data file (.OST) or corrupted data file.
4. Corrupted or problematic Outlook profile.
5. Duplicated Office Library files that point to different version of Outlook.
6. The Redemption keys in the registry are corrupted.
7. Existence of the Redemption key.
8. If user is on Windows 7, the User Account Control is set to high (see Turn off User Account Control in Windows).
9. Different versions of Office are installed and the older version was installed or changed recently.
10. Corrupted MsMAPI.dll or Mapi32.dll (depending on your Office installation) 
11. A problematic or corrupted installation of Microsoft Office that would show different bitness in UI vs Registry. 

 
Example 1: User has Outlook 2010 and Office 2013 and Office 2010 was updated/changed/installed recently after Outlook 2013 was installed
 
Example 2: Office Business Edition (including Outlook 2010 or 2016) and Office Home Edition (no Outlook) and Home Edition was updated/changed/installed after Office Business Edition
 
In a Windows 7, 8, 10 operating systems you can check the date on the Programs and Features windows
 
Løsning
1. Microsoft Outlook is not running
Simply Open Outlook or if it is open, close it and wait a few seconds then reopen it

2. Microsoft Outlook or SFO are running as Administrator
Exit SFO and Outlook first, then right click on SFO and click on Properties and click on Compatibility tab and make sure none of the boxes are checked.

Do the same thing for Outlook, again make sure Outlook is closed and you need to hold down the SHIFT key on your keyboard and right click on the Outlook icon on the Desktop or Taskbar and click on Properties and click on Compatibility tab and make sure none of the boxes are checked.

3. Missing Outlook data file (.ost) or corrupted data file
Make sure Outlook is running in Exchange cached mode and if it is already running in the cache mode and there is a data file (.ost) file on the machine, you may need to recreate it. See Enable Exchange Cached Mode for Microsoft Outlook.

Sometimes a duplicate or corrupted Outlook profile also can cause this issue. SFO gets confused and is unable to connect to the correct profile

4. Corrupted or problematic Outlook profile
You don't need to make any changes to the existing Outlook profile. To test and make sure the problem is not related to Outlook profile, you can create a new no email profile in Outlook and try to run the wizard and see if the folders will display correctly

To do this, follow these steps:

1. Close Outlook and then from Control Panel double click on the Mail icon ( you can also search for it using the Search box on top corner)
2. On the Mail Setup pop up box, click on Show Profiles...
3. Make sure the When starting Microsoft office Outlook, use this profile:  radio button is set to Prompt for a profile to be used
4. Click on Add... and type in a name such as Test-profile in the New Profile window and click on OK
5. The Add New E-mail Account wizard will start automatically, you can click on Cancel
6. You will see the 'Microsoft outlook' pop up box with message: If you want to create a new outlook account, click OK. If you don't want to create a profile at all,click cancel
7. Click OK, click on OK again to close the Mail window. 

Open Outlook and select the new profile and then run SFO and retry the wizard and see if the folders are still grayed out. If they are not and you are able to see and select a folder, then the user's existing Outlook profile is corrupted and you should have the user or their IT team recreate it for them

Important: You can also reach out to your (customer's) IT team to create a new Outlook profile

5. Duplicated Office Library files that point to different version of Outlook
 
You need to check the registry for any duplicated key.

To open the Registry Editor press the Win(key) + R key combination on your keyboard and type REGEDIT and press Enter

 
In the Registry Editor navigate to HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}

Under this key you should only have one key since each key references to the version of Microsoft Outlook installed on your computer.

Keys for corresponding version of Microsoft Outlook installed on your computer
 
9.2       for       Office 2003
9.3       for       Office 2007
9.4       for       Office 2010
9.5       for       Office 2013
9.6       for       Office 2016
9.7       for       Office 2019

For example, if you had Office 2007 on your computer and then upgraded or installed Outlook (or Office) 2010 a second key will get created here. Then, you change your mind and you uninstall the Office 2010 version and continued using the Outlook 2007. Sometimes the uninstaller does not remove the corresponding key. So you would end up with 2 keys one for Outlook 2007 and another for 2010. You would need to keep the 9.3 key and remove the 9.4 key.
 
If there is only one entry here, skip to the next step. ** DO NOT close the Registry Editor yet
Example 1: If a user has only Outlook 2007 installed they will see only the 9.3 key
Example 2: If user has Outlook 2010, and there are two entries 9.3 and 9.4, you need to right click on the 9.3 key (that refers to Outlook 2007) and click on Delete

6. The Redemption keys in the registry are corrupted
 

Next delete the following key(s) from the registry as well and then close the Registry (there might be more than 1 Redemption entry, delete them all). No need to save them.

HKEY_CURRENT_USER\Software\Redemption
HKEY_CURRENT_USER\Software\Redemption *
HKEY_CURRENT_USER\Software\Redemption * *
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Redemption

7. An instance of the Redemption key
With old installation of SFO, a redemption key that would indicate the version of the Redemption would get created and inserted in the registry. This key is not necessary anymore with SFO v3.0 and new versions and you need yo delete this key.
 
Navigate to HKEY_CLASSES_ROOT\TypeLib\ and locate this key {2D5E2D34-BED5-4B9F-9793-A31E26E6806E} and right click on it and click on Delete

8. If user is on Windows 7, the User Account Control is set to high (see Turn off User Account Control in Windows)
If STEP 8 (Setting the Windows 7 UAC (User Account Control) to Never Notify (Turn off User Account Control in Windows) ) did not fix the issue skip to STEP 9.
 

9. Different versions of Office are installed and the older version was installed or changed recently.

A. Make sure Outlook is closed.

B. Uninstall Salesforce for Outlook as well as the following applications:
Visual Studio® 2010 Tools for Office Runtime (x64) (VSTO)

If you have Outlook 2010:
Outlook 2010 users: Uninstall the ‘Office 2010 Primary Interop Assemblies’ 
 
If you have Outlook 2007:
Outlook 2007 users: Uninstall the ‘Office 2007 Primary Interop Assemblies’
 
For Outlook 2013 and later, PIA is included as part of Office installation as part of .NET Programmability option
 
Refer to Install Primary Interop Assemblies and Office Visual Studio Runtime manually for SFO installation if user has Office 2013
Windows 7/8/10: Control Panel\All Control Panel Items\Programs and Features

Note: These may be slightly different depending on the version of your Windows and Outlook.

C. Run a repair on Office installation. Make sure you repair the version that includes your Microsoft Outlook. From Control Panel, list of programs select the version of Office you would like to repair and click on ‘Change’ and make sure ‘Repair’ is selected and finish the process
Note: If you have Office 2013 Click to Run or Office 365, you must perform an Online Repair - Do not do a Quick Repair.
 
D. Wait until repair process is done and then reboot your computer. Do not skip this step please.

E. After you restart, navigate to
For Windows 8, 8.1 and 10 users: %AppData%\salesforce.com\Salesforce for Outlook\ and delete everything.

10. Corrupted MsMAPI.dll or Mapi32.dll
 
1. First close all your programs, including SFO. To Exit SFO, right click on the system tray icon and click on Exit.
2. Run CMD as administrator or using another local admin credentials.
3. Run the command below and press Enter. You should see the SUCCESS: The file now owned by user "username" message.
Takeown /F c:\windows\system32\mapi32.dll​
​​4. ​N​ext rename ​the mapi32.dll file to mapi32.dll.old by using the command below.
Rename c:\windows\system32\mapi32.dll   mapi32.dll.old
5. You can run the DIR command for mapi32.* ( command:  Dir mapi32.*  ) to list all the files with that name and any extension to see if the file extension has changed. Please see the example of these commands below as well as the screen shot. You can also navigate to C:\windows\system32 folder and search for Mapi32 and to make sure the file has been renamed. The extension must be visible though otherwise you wont see the .dll or .old and you would only see the file name.
6. Finally when file is renamed, run the Fixmapi.exe command to create a new instance of the mapi32.dll
7. Open Outlook and then run SFO.
8. Try to reproduce the issue.

Link to related image

Please see an example of these commands step by step
 

C:\windows\system32>takeown /F c:\windows\system32\mapi32.dll   
*T
o take ownership of the mapi32.dll file - in this example since its from my own machine its my username but you would see your domain\username instead

SUCCESS: The file (or folder): "c:\windows\system32\mapi32.dll" now owned by user "SFDC\JohnDoe"
.
C:\windows\system32>rename c:\windows\system32\mapi32.dll mapi32.dll.old                  ** T rename the mapi32.dll to mapi32.dll.old

C:\windows\system32>Dir mapi32.*                     *** To list all the files name mapi32 with any extensions 

 Volume in drive C is OSDisk
 Volume Serial Number is 940A-997E

 Directory of C:\windows\system32

10/28/2014  07:36 PM           102,912 mapi32.dll.old
               1 File(s)        102,912 bytes
               0 Dir(s)  356,389,900,288 bytes free

C:\windows\system32>fixmapi                 **** To create a new instance of the mapi32.dll file

C:\windows\system32>dir mapi32.*         ***** To confirm a new instance of the mapi32.dll is created
 Volume in drive C is OSDisk
 Volume Serial Number is 940A-997E

 Directory of C:\windows\system32

10/28/2014  07:36 PM           102,912 mapi32.dll
10/28/2014  07:36 PM           102,912 mapi32.dll.old
               2 File(s)        205,824 bytes
               0 Dir(s)  356,389,793,792 bytes free

Now try to reproduce the issue.
 

11. A problematic or corrupted installation of Microsoft Office that would show different bitness in UI vs Registry. 

With certain Office installations, the Outlook gets installed with 2 different bitness, in the Registry vs in the UI. To make sure the installation has been done correctly, check the Outlook bitness in the UI and compare it to the bitness value in the registry. If these values do not match, refer to the customer's IT team to correct the issue. They may have to reach out to Microsoft for more support.

Open Outlook and click on File | Office Account on the left menu and click on About Outlook
Refer to Check the version of Salesforce for Outlook Knowledge article.

Now hold down the windows key on your keyboard and press the R key to open up the RUN box and type in Regedit and press enter to open the Windows Registry. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office depending on which version of Office you have installed, this number varies. Refer to the table below for more information


 
Office version Registry key number  xx.0
2016 and O36516.0
201315.0
201014.0
200712.0

For instance, if you have Office 2016 installed, look under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office \16.0\Outlook 
Click on Outlook and see what you see on the right side for the bitness.
Note*
X86 means 32bit and x64 means 64bit. This value must match the value in Outlook UI when you click on About Outlook

Link to related image

If you see any 15.0 or 14.0 folders here under Office, ask their IT to remove it if there is an Outlook sub folder. Open them and check to see if Outlook folder exist. Also if it does, check to see if there are any other versions of office installed. We need to uninstall and delete the extra keys (15.0 and 14.0 if include Outlook) and uninstall other instances of Office that include Outlook. For instance, they cant have Office 365 and Office or Outlook 2013 installed. Only one instance of Office must be on the machine for SFO to work

So to recap, you need to compare the bitness in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\xx.0\Outlook with Outlook | File |Office Account | About Outlook and for SFO to work these numbers must match, If they don't, they have to fix this issue before we can help them install SFO on that machine.
 

Note:
Our next-generation products, Outlook integration and Lightning Sync, are better than ever and ready to serve you. Check out the trail for Outlook Integration for product details and setup instructions.

 

 
 
Knowledge-artikkelnummer

000384943

 
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Salesforce Help | Article