Loading

Salesforce for Outlook が起動せずシステムトレイにアイコンが表示されません

公開日: Jan 31, 2022
説明

問題

-  Salesforce for Outlook (SFO) をインストールしましたが、画面右下のシステムトレイに SFO アイコンが表示されません。
-  SFO アイコンをダブルクリックして起動しようとしましたが、システムトレイまたはプロセスタブ ([タスクマネージャ] | [プロセス] タブ) にロードされません。
プロセス名: SfdcMsOl.exe
 

Task Manager Processes tab showing the SFO process

解決策

考えられる原因:

この問題は次の 2 点に関連している可能性があります。
 

1- SFO を互換モードで実行する
2- Windows のインストールまたはコンピュータイメージの破損

 

SFO を互換モードで実行する

SFO をインストール後、以下の手順を行ってください。

1. デスクトップの SFO アイコンを右クリックし、[プロパティ] をクリックします。

2. [互換性] タブをクリックします。

3. [互換モード] セクションの [互換モードでこのプログラムを実行する][特権レベル] セクションの [管理者としてこのプログラムを実行する] のチェックが外れていることを確認します。

Salesforce for Outlook Properties

※ SFO のインストールおよび実行には、エンドユーザ認証情報を使用します。

4. [OK] をクリックします。SFO を起動して問題が解消されたかを確認します。


 

Windows のインストールまたはコンピュータイメージの破損

SFO が正常に実行されていてもシステムトレイにアイコンが表示されない場合は、お使いの Microsoft Windows が破損しているか、またはコンピュータに間違ったビット数のアプリケーションがインストールされている可能性があります。

1. Windows のスタートをクリックし、検索ボックスに以下のように入力して、Salesforce のインスト-ルフォルダへ移動します(Windows 8 をお使いの場合は、スタートを右クリックして '検索' を選択します)。
 %AppData%\salesforce.com\Salesforce for Outlook\logs 

2. Logs フォルダ内の Trace.log ファイルを Windows のメモ帳 (またはその他のテキストエディタ) で開きます。

3. 「Wrong OS」を検索して、以下のような表記がないか確認します。

System.Runtime.InteropServices.COMException (0x800401FA): Wrong OS or OS version for application (Exception from HRESULT: 0x800401FA (CO_E_WRONGOSFORAPP))

4. さらに、%AppData%\salesforce.com\Salesforce for Outlook\ フォルダ内で以下のファイルの有無を確認します。

32 ビット版の Outlook (x86) をご使用の場合は sfdcrdm.dll ファイル
64 ビット版の Outlook をご使用の場合は sfdcrdm64.dll ファイル
使用する Outlook のビット数と一致する DLL ファイルが 1 つだけ存在することを確認します。これらの点が正しくないと SFO のインストーラは OS のビット数を確認することができません。

5. 多くのお客様が Windows を Windows 7 から 8 へ、あるいは Windows 8 から 8.1 へアップグレードしていますが、アップグレードの際に何らかの理由で OS のビット数が変更されます。たとえば Windows 7 32 ビット版 (x86) をアップグレードした後に、 Windows 8 64 ビット版 (x64) に変わることがあります。 オペレーティングシステムにおけるこのような変更をアプリケーションが認識できず、その実行に失敗します。また、アプリケーションが OS のビット数を確認できないために、間違った DLL ファイルや 2 つの DLL ファイル(32 ビットと 64 ビット)がインストールフォルダに置かれることになります。この問題を解決する最も簡単かつ最速の方法は、Windows を再インストールすることです。お客様の社内ヘルプデスク (IT チーム)にご相談されることをお奨めします。

** 社内ヘルプデスクを利用できない場合に Windows の再インストールを実施する際は、必ず事前に Windows インストールキーをご準備ください。

 

 

ナレッジ記事番号

000385114

 
読み込み中
Salesforce Help | Article