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Error 'Salesforce for Outlook was unable to open successfully'

Date de publication: Oct 13, 2022
Description

Issue

When User double-clicks on the Salesforce for Outlook (SFO) icon in the system tray to run it, the error message below pops up and SFO never runs:
 

"Salesforce for Outlook was unable to open successfully. You'll need help from your administrator to resolve this issue. Provide your administrator the content of this error."



Root Cause

There is a version mismatch in the GAC with the Interop assembly. Depending on the version of the Microsoft Office installed on the machine such as Office 2010 or 2007, the interop Assembly version installed and used must match the Office installation. For example, Office 2010 uses the Interop version 14 and Outlook 2007 uses the version 12 and so on.
 

Résolution

 

This is not a Salesforce issue and most probably is related to Microsoft Office installation on the machine.

To fix this issue, you need to uninstall Salesforce for Outlook first and its dependency applications (Primary Interop Assemble and Visual Studio Run-time) and then reinstall Office. Once this is done, restart your computer and install SFO.

Please follow the steps below:
  1. Make sure Outlook is closed.
  2. Uninstall Salesforce for Outlook as well as the following applications from Windows 7, 8, 8.1, 10:
Go to this directory: Control Panel\All Control Panel Items\Programs and Features
 
  • Visual Studio® 2005 Tools for Office Second Edition Runtime
OR
  • Visual Studio® 2010 Tools for Office Runtime (x64)  

If you have Outlook 2013/2016 or 365:  
  • Office 2013/2016 users: Make sure the .NET Programmability support is installed as part of your Office installation
  •  Office 365 Users: run an online repair on your office installation to make sure the .NET Programmability support get installed
 
If you have Outlook 2010:
  • Uninstall the ‘Office 2010 Primary Interop Assemblies’ 
 
If you have Outlook 2007:
  • Uninstall the ‘Office 2007 Primary Interop Assemblies’  
 
  1. Open Windows Registry Editor by:
Windows 7, 8, 8.1, 10:
Click on Start and type in Regedit in the Search box and press Enter
 
  1. In the registry editor, navigate to
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\{00062FFF-0000-0000-C000-000000000046}
 
  1. Under this key you should see one key only that corresponds to the version of Microsoft Outlook you have installed.
 
9.2 for Office 2003
9.3 for Office 2007
9.4 for Office 2010
9.5 for Office 2013
9.6 for Outlook 2016 or 365

For example, if you had Office 2007 on your computer and then installed Outlook (or Office) 2010 installed, and the uninstalled the 2010 version and started using the outlook 2007 again. Sometimes the uninstaller does not remove the corresponding key. So you would need to keep the 9.3 key and remove the 9.4 key.

If there is only one entry here, skip step 5 and move on to the next step
 
  1. Next delete the following key(s) from the registry as well and then close the Registry (There might be more than 1 Redemption entry, delete them all) No need to save them
HKEY_CURRENT_USER\Software\Redemption
HKEY_CURRENT_USER\Software\Redemption * HKEY_CURRENT_USER\Software\Redemption * * HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Redemption

 
  1. Next, locate the Microsoft Office version that your Outlook belongs to (for example, if you see more than one Microsoft Office installation in list of installed programs, such as Office 2007 standard Edition and Microsoft Office 2010 profession, find out what version of Outlook you have installed (Outlook 2007 or 2010) and then uninstall that version of Microsoft Office.
 
  1. Make sure you restart after the uninstall is done.
 
  1. We would recommend running a clean up utility program to clean the registry and duplicate folders that could possibly point to the wrong version of Office shared library. Its best to have your IT department perform this step.  Applications such as TuneUp Utilities or any other utilities.
Note this is a 3rd party applications and Salesforce is not responsible nor supports it.
 
  1. Next, install Microsoft Office completely with all its features.
 
  1. After you install Office, run Windows Update to make sure you have the latest updates and Service Packs installed on the machine.
 
Office 2007 needs Service Pack 3
Office 2010 needs Service Pack 2
Office 2013 needs Service Pack 1
 
 
Download Locations for Microsoft Office Service Packs

Microsoft  Office Version   

 Service   Pack                    

Size(MB)       

 Download   

Office 2013

SP1

643.6

32-bit

SP1

774.0

64-bit

Office 2010

SP2

638.2

32-bit

SP2

730.4

64-bit

Office 2007

SP3

351.0

32-bit

 
  1. Next, navigate to %appData%\salesforce.com\Salesforce for Outlook\ and delete the “Resources” and "DB" folders. It is safe to delete all the folders from this location.
 
  1. Login to Salesforce.com and download the Salesforce for Outlook plug-in and run the installer. Do not run it as administrator. If you are a local administrator run it normally and choose the Everyone option during the install. If you do not have admin privileges, ask your IT to install it for you. 
 
  1. Finish the installation and make sure the Salesforce for Outlook runs in the Taskbar and try to reproduce the issue.


For Office 2013/2016 users please make sure to check this extra step
  1. Navigate to Control Panel\Programs\Programs and Features. Or just click on Start button and enter appwiz.cpl in the Search box then press Enter.
  2. Select your Microsoft Office 2013 installation and click on Change on top.
  3. Choose Add or Remove Features.
  4. Expand Microsoft Office Outlook and Make sure .NET Programmability Support is set to "Run from My Computer." If it is not selected, select it and click on Continue and allow the Office installation to update the files.
Note:
If you have Office 365 or Office Click to Run, you wont see the Add or Remove Features or the Repair option after you click on Change, instead you will see Quick Repair or Online Repair.

You need to select Online Repair and complete the repair and restart your computer. this will make sure all the necessary files are installed.
  1. Run Salesforce for Outlook and Outlook.


See also
Salesforce for Outlook System Requirements

 
Numéro d’article de la base de connaissances

000385554

 
Chargement
Salesforce Help | Article