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SFO エラー「Salesforce for Outlook was unable to open successfully」

公開日: Jun 18, 2021
説明
問題:

システムトレイの Salesforce for Outlook (SFO) アイコンをダブルクリックして実行すると、以下のエラーメッセージが表示され、SFO は実行されません。

User-added image


根本原因:

相互運用機能アセンブリで GAC にバージョンの不一致があります。Office 2010 や 2007 など、コンピュータにインストールされている Microsoft Office のバージョンに応じて、インストールされ使用されている相互運用機能アセンブリのバージョンは、Office のインストールと一致する必要があります。 たとえば、Office 2010 は相互運用機能バージョン 14 を使用し、Outlook 2007 はバージョン 12 を使用します。
解決策

解決策:

これは Salesforce の問題ではなく、コンピュータ上の Microsoft Office のインストールと関係があります。

この問題を解決するには、Salesforce for Outlook とその依存関係アプリケーション (プライマリ相互運用機能と Visual Studio ランタイム) をアンインストールしてから、Office を再インストールする必要があります。それが完了したら、コンピュータを再起動して、SFO をインストールします。

次の手順に従ってください:

1. Outlook が終了していることを確認します。

2. 以下のアプリケーションと同様に Salesforce for Outlook をアンインストールします。

Windows 7、8、8.1、10 では: コントロール パネル\すべてのコントロール パネル項目\プログラムと機能

から
 
- Visual Studio® 2005 Tools for Office Second Edition Runtime
または
 - Visual Studio® 2010 Tools for Office Runtime (x64)
 
Outlook 2013/2016、または 365:の場合::
  - Outlook 2013/2016ユーザは: .NET プログラミングサポート が Office 一部としてインストールされていることを確認
します。
  - Office 365 ユーザは、.NET プログラミングサポートがインストールされていることを確認するために、Office インストールのオンライン修復を実行します。
記事番号 000228559 を参照してください。

Outlook 2010 の場合:
  - Outlook 2010 ユーザは Office 2010 プライマリ相互運用機能アセンブリをアンインストールします。 

Outlook 2007 の場合:
  - Outlook 2007 ユーザは Office 2007 プライマリ相互運用機能アセンブリをアンインストールします。
 
3. Windows レジストリエディタを以下の手順で実行します:

Windows Vista,、7、8、8.1、10: [スタート] をクリックし、Regedit と入力して、Enter キーを押下します。

4. レジストリエディタで、以下のキーへアクセスします
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\{00062FFF-0000-0000-C000-000000000046}

5. このキーの下に、インストールした Microsoft Outlook のバージョンに対応するキーのみが表示されます。
 
Office 2003 では、9.2
Office 2007 では、9.3
Office 2010 では、9.4
Office 2013 では、9.5
Office 2016 または 365 では、9.6
 
たとえば、コンピュータに Office 2007 がインストールされていて、Outlook (または Office) 2010 がインストールし、その後に 2010 バージョンがアンインストールされ、Outlook 2007 が再び使用されたとします。 アンインストーラによって対応するキーが削除されないことがあります。 したがって、9.3 キーを保持し、9.4 キーを削除する必要があります。 ここにエントリが 1 つしかない場合は、手順 5 をスキップして次の手順に進みます。

6. 次に、レジストリから次のキーを削除し、レジストリエディタを閉じます (1 つ以上の Redemption エントリが存在する可能性があります。すべて削除してください)。保存する必要はありません。
 
HKEY_CURRENT_USER\Software\Redemption
HKEY_CURRENT_USER\Software\Redemption *
HKEY_CURRENT_USER\Software\Redemption * *
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Redemption

注意:
レジストリの編集内容に問題があると、システムが正常に動作しなくなる場合があります。 特に、誤ったキーを削除することにより、Windowsが起動しなくなることもありますので 十分に注意して実施してください。


 
7. 次に、Outlook が含まれる Microsoft Office のバージョンを確認します (たとえば、Office 2007 Standard Edition や Microsoft Office 2010 Professional Edition など)。インストールされているプログラムの一覧に複数の Microsoft Office がインストールされている場合は、 インストールした Outlook (Outlook 2007 または2010) を確認し、そのバージョンの Microsoft Office をアンインストールします。

8. インストールの完了後に、再起動します。

9. レジストリをクリーンアップし、誤ったバージョンの Office 共有ライブラリを指す可能性のあるフォルダを複製するユーティリティプログラムを実行することをお勧めします。貴社の IT 部門にこの手順の実行を依頼することが最善です。TuneUp ユーティリティやその他のユーティリティなどのアプリケーション。

これはサードパーティのアプリケーションであり、Salesforce はその責任を負いませんし、サポートもしていません。

10. 次に、すべての機能を備えた Microsoft Office を完全にインストールします。

11. Office をインストールした後、Windows Update を実行して、最新の更新プログラムと Service Pack がコンピュータにインストールされていることを確認します。

Office 2007 では、Service Pack 3 が必要です
Office 2010 では、Service Pack 2 が必要です
Office 2013 では、Service Pack 1 が必要です
 
Microsoft Office Service Pack のダウンロード

Microsoft
Office バージョン

Service
Pack

サイズ
(MB)
 

ダウンロード

Office 2013

SP1

657.4

32-bit

SP1

788.1

Office 2010

SP2

646.4

32-bit

SP2

735.7

64-bit

Office 2007

SP3

385.7

32-bit

 

12- 次に、%appData%\salesforce.com\Salesforce for Outlook\ へアクセスし、「Resources」および 「DB」フォルダを削除します。この場所からすべてのフォルダを削除することは安全です。
 
13. Salesforce.com にログインし、Salesforce for Outlook プラグインをダウンロードしてインストーラを実行します。それをシステム管理者として実行しないでください。ローカル管理者の場合は、通常はそれを実行し、インストール中に [このコンピュータにログインする全員] オプションを選択します。管理者権限がない場合は、貴社の IT 担当者にインストールを依頼してください。
 
14. インストールを完了し、Salesforce for Outlook がタスクバーで実行されていることを確認します。そして、問題の再現を試みます。


Office 2013/2016 では、さらに以下を確認してください:
1. コントロール パネル\すべてのコントロール パネル項目\プログラムと機能.へアクセスします。

2. Microsoft Office 2013 インストールを選択し、上部の [変更] をクリックします。

3. [機能の追加/削除] を選択します。

4. Microsoft Outlook を展開し、[.NET プログラミング サポート] が [マイコンピュータから実行] に設定されていることを確認します。

選択されていない場合は、それを選択して [続行] をクリックして、Office インストールでファイルを更新できるようにします。

注*
Office 365 または Office Click-to-Run を使用している場合は、[変更] をクリックした後に [機能の追加/削除] または [修復] オプションが表示されません。代わりに [クイック修復] または [オンライン修復] が表示されます

[オンライン修復] を選択して修復を完了し、コンピュータを再起動する必要があります。 これにより、必要なファイルがすべて確実にインストールされます。


5. Salesforce for Outlook および Outlook を実行します。

参考資料:
Salesforce for Outlook のシステム要件

 
ナレッジ記事番号

000385554

 
読み込み中
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