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Add Email with Salesforce for Outlook

Publish Date: Aug 29, 2024
Description

List of all the knowledge articles mentioned below


Before you start, we recommend reviewing the following articles for more information on how email association works.


 

Common Troubleshooting techniques when Email association fails using the Add Email button (not the Side Panel)

1. Take Outlook offline
2. Select email and click Add Email button. Check the Outbox.
3. You must see one email in Outbox. The original selected email is now added as attachment to this new email with Email To Salesforce address in To field.

If this information is correct, make Outlook online again and see if you have connectivity to the internet and can send email.
If the email can be sent successfully then the plugin is working properly. If the email does not send, please contact Salesforce support for further investigation. Please also contact your IT department as the issue may be related to your company firewall. When contacting support please provide the time and date when you attempted to add the email, and attach the log files for Salesforce for Outlook for that time frame.
Resolution

Scenario #1

Users are unable to add an email from the Side Panel by clicking on the add email envelope icon. Side Panel displays this error message in red. 
Error in getting contacts:

SidePanelExceptionError in  getting contacts:
SidePanelExceptionError in getting contacts:
SidePanelException   
No Matching Contacts or Leads

It appears to be working but then stops and the envelope icon never turns green. 

Root Cause

The NameComment and Due Date fields of the Task Object are not visible for the affected user's profile and the FLS (Field Level Security) is set to Hidden

Resolution

Unable to Add Email using Salesforce for Outlook Side Panel - Error in getting contacts


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Scenario #2

Attempting to associate an email to a record in Salesforce throws an error message after clicking on the envelope icon next to the record name. This can occur when selecting an email from the Outlook Inbox or any email folder. It may also happen when composing a new email or replying to an email. Selecting an email from the Outlook Inbox or any other folder, composing a new email, or even replying to an email and trying to associate that email to a record in Salesforce using the Side Panel, the Side Panel throws an error message on top after you click on the Envelope icon next to the record name. 

The error reads:
We couldn't add this item. Please try adding this item again. 

Root Cause

Possible causes could be any one or more of the following:
- A validation Rule on the Task object
- A workflow Rule
- An Apex trigger
- Email body/content is too large (Description field) 

Resolution

 Salesforce for Outlook Side Panel error when trying to add an email 'We couldn't add this item. Please try adding this item again.'


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Scenario #3

The small Add email envelope icon is not visible in the Side Panel

Root Cause

The Add Email option is not enabled for your organization

Resolution

The Add Email icon is missing from the SFO Side Panel


 

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Scenario #4

Clicking on the envelope icon in the side panel adds the email to a Salesforce record but when you select an attachment, it fails with the error;

We could not add this item. Please try adding this item again. 


SFO log file would contain

2015-08-07 13:21:18,675 [VSTA_Main ] WARN adxsidepanel ::JAVASCRIPT::ERROR::AssociationError::xhr=[object Object]:status=error:error=Unauthorized:xhr.message=Session expired or invalid:xhr.code=INVALID_SESSION_ID:xhr.fields=undefined
2015-08-07 13:21:18,679 [VSTA_Main ] WARN adxsidepanel ::JAVASCRIPT::We couldn't add this item. Please try adding this item again.
2015-08-07 13:21:18,805 [VSTA_Main ] WARN adxsidepanel ::JAVASCRIPT::ERROR::We couldn't add this item. Please try adding this item again.

Root Cause

In reality this issue is not related to SFO or its settings. You would need to disable the "Lock sessions to the IP address from which they originated" in the impacted orgs.
Resolution

Salesforce for Outlook: Emails are added but adding attachment fails - “We couldn't add this item. Please try adding this item again"

 

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Scenario #5

Emails added to Salesforce disappear from Outlook

Root Cause

Email category is changed and due to Outlook current view they may move to the bottom of the list
Resolution

Salesforce for Outlook - Emails added to Salesforce disappear from Outlook

 

Knowledge Article Number

000385729

 
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