Loading

Error 'Value does not exist or does not match filter criteria' when Quote Line Item is added

Julkaisupäivä: Jun 3, 2026
Kuvaus
Steps to reproduce:

1. Open a Quote Record
2. Click “Add Line Item” in the Quote Line Items Related List
3. Choose any of the products listed and click “Select”
4. Enter a Quantity and click Save


Error: Value does not exist or does not match filter criteria.

Ratkaisu

Root Cause

When a Quote Record is synced to an Opportunity, any update to the Quote triggers validation rules on the Opportunity — including Lookup Filter validations — even if the relevant field is not on the page layout.

 

Resolution Steps

Updating the Quote Record that is being synced causes an update on the Opportunity and as a result, validations are run and Filter Lookup Validations trigger even if the Field is not on the page layout.

Ensure there are no Lookup Filters on the Opportunity and if there are, ensure the Opportunity Record in question still meets the criteria (just hit edit and save and see if validations fire).



Lisäresurssit

Lookup Filters ​​​​​​​

Knowledge-artikkelin numero

000386237

 
Ladataan
Salesforce Help | Article