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Unable to add email with the Salesforce for Outlook Side Panel

Fecha de publicación: Oct 13, 2022
Descripción

ISSUE

Users are unable to add an email from the Side Panel by clicking on the small envelope icon next to a record. Side Panel displays an error message in red and would try to add the email but then it stops and the envelope never turns green. 

After clicking on the envelope you may see the error:

"Error in getting contacts: SidePanelExceptionError in getting contacts:  SidePanelExceptionError in getting contacts:  SidePanelException. No Matching Contacts or Leads in Salesforce"

 

Note: This error may be different with different versions of SFO

CAUSE
The Name, Comment, and Due Date fields of the Task Object are not visible for the affected user's profile and the FLS (Field Level Security) is set to Hidden

Solución

To fix this issue you need to ask your Salesforce Administrator to


1. Login to Salesforce as Administrator and click on:

Classic: Setup | Customize | Activities | Tasks Fields
Lightning: Setup | Object Manager | Task | Fields & Relationships 

2. Click on Name under the Field Label column then click on Set Field Level Security.

3. You will notice that the visible checkbox for the field is not checked for the affected user's profile. Check the box and save it.

4. You need to repeat the steps in STEP 3 above for the "Comment" and "Due Date" fields as well.

5. Also if you click on New Task from the affected user's Home tab, you probably won't see the Name, Comment, and Due Date fields.

6. After you make this change, close and reopen SFO by right-clicking on the SFO system tray icon at the bottom right corner of the screen and click on Exit and run it from the Desktop and try to reproduce the issue.
Número del artículo de conocimiento

000386355

 
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Salesforce Help | Article