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Dashboard access error: "Insufficient privileges"

Udgivelsesdato: May 26, 2026
Beskrivelse

Issue Description

In Salesforce, users with certain license types may encounter an 'Insufficient Privileges' error when attempting to access a dashboard. This error occurs because these license types have restrictions on dashboard visibility based on the Running User's license.

Affected License Types

  • Chatter
  • Force.com Lightning Platform
  • Customer Portal
  • Company Community Portal
  • Partner Portal

Root Cause

For a non-Dynamic Dashboard: The error occurs because the Running User assigned to the dashboard has a different (typically higher) license type than the user attempting to view it. For a Dynamic Dashboard: The error occurs because the original Running User or creator of the dashboard holds a full Salesforce license, which is not accessible to users with restricted licenses.

Løsning

Resolution Option 1 — Grant Permission

Provide the user with the 'Manage Dashboards in Public Folders' permission. See Enhanced Folder Sharing in Reports and Dashboards for steps.

Resolution Option 2 — Reconfigure Dashboard Running User

In Salesforce Classic

  1. Access the dashboard, then click Edit.
  2. Next to View dashboard as,' click the dropdown and select Run as a specified user, then click OK.
  3. In the 'View Dashboard as' field, enter the name of a user with a Salesforce Platform license. Click the name when it appears.
  4. Next 'View dashboard as,' click the dropdown and select Run as logged in user, then click OK.
  5. Click Save.

In Salesforce Lightning

  1. Access the dashboard, then click Edit.
  2. Click the Edit Dashboard Properties icon (gear icon).
  3. Under 'View dashboard as,' select Another person.
  4. Enter the name of a user with a Salesforce Platform license. Click the name when it appears.
  5. Click Save.  
Vidensartikelnummer

000387032

 
Indlæser
Salesforce Help | Article