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Unable to sync Outlook records with Salesforce after sync configuration set to automatic

Publish Date: Apr 7, 2023
Description
ISSUE
After changing your Salesforce for Outlook sync configuration from Manual to Automatic, you might notice that your Outlook records are still not syncing with Salesforce. 
   

Possible Cause
This happens when you install Salesforce for Outlook (SFO) and choose Manual as your sync configuration during the initial SFO wizard.

 

To set your sync configuration:
 
1. Right-click on the system tray. 
2. Click Settings.
3. Access the setting for Choose Which Outlook Items to Sync to Salesforce.
4. Take note of your selection: 
  • Sync All Outlook Items - this syncs the entire records in your Outlook (event or contact based on the configuration)
  • Sync Only the Outlook Items I Select - the plugin lets you decide what you want to sync by categorizing the events as "Sync to Salesforce" or "Don't Sync to Salesforce"
 
 
Resolution
 
Since this configuration requires records to be manually categorized as "Sync with Salesforce", turning off this setting leaves all Outlook records in the "Don't sync with Salesforce" category, hence they will not be synchronized with Salesforce even though the configuration is now set to Automatic (Sync All Outlook items).
 

You can fix this by following these steps:

 
1. Open Outlook:

In Outlook 2007: Click on the Contact folder then click on View | Current View | By Category
In Outlook 2010, 2013, 2016, or O365: Click on the View tab then click on Change View and select List

2. Now you should see a Category column.

3. Select all the records categorized as "Don't sync with Salesforce" by holding down the Alt key on your keyboard and clicking on each contact or to select all, hold down the Shift key on your keyboard and select the first contact and then scroll down and click on the last contact.

4. Then right-click on one of the selected contacts.

5. Click on the Categorize option on the pop-up menu.

6. Select "Don’t Sync with Salesforce” category to uncheck it.


After this, you should be able to sync these records with Salesforce. For more information about these two categories and the manual vs automatic sync, please review Salesforce for Outlook Sync selection in the SFO wizard.



 
Knowledge Article Number

000387136

 
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Salesforce Help | Article