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'Invalid Token' error - MobilePush Sends not received by iOS devices

Дата публикации: Oct 15, 2024
Описание

You may receive an 'Invalid Token' error which states that MobilePush messages have not been received on all iOS devices.
 

This error may be caused by one of the reasons below:

Решение

Possible Causes

A) Certification mismatch by environment

The developer certification is registered when the production certification should have been registered.

A developer certification for iOS is only used if the end user is testing a phone device that is plugged into their computer. The production certification is used for every other use of testing and developing MobilePush for iOS.
 

B) App BundleID does not match

The BundleID is the unique ID for their application for iOS. The BundleID name in the certificate must match the BundleID name in the Marketing Cloud App, within Administration of MobilePush. 

Each iOS application on the Apple App Store must have a unique name. The App BundleID is under the APNS Certification name (For example: com.exacttarget.internal.PublicDemo).

If the Marketing Cloud App and application App BundleID do not match, you will receive the 'Invalid Token' error.

Check to make sure that your Certificate value matches what your application is sending from.

  • If you debug in Xcode to a connected device, your push notification environment is considered Development. You must use an Apple Push Notification service SSL (Sandbox) certificate on the MobilePush Administration screen in Marketing Cloud.
  • If you build and install the LearningApp as an archive or via app distribution such as TestFlight, Hockey, or Fabric, your push notification environment is considered Production. You must use an Apple Push Notification service SSL (Sandbox & Production) certificate on the MobilePush Administration screen in Marketing Cloud.


C) The users have uninstalled the app
Apple does not have a feedback loop to unsubscribe users who uninstall the app. We only receive feedback when sends occur to devices with invalid tokens. 

Resolve the 'Invalid Token' error

1. Validate that the production mobile app certificate is being used and not the developer version of the mobile app certificate.
2. Make sure the BundleID name for the certificate matches the BundleID name in the Marketing Cloud App.
 

Tip: Review our helpful references for provisioning iOS applications and setting up mobile applications on GitHub.

Номер статьи базы знаний

000388009

 
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Salesforce Help | Article