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Troubleshooting NPSP Gift Entry error: "Secure Query Included Inaccessible Field" after adding a Contact or Account along with spinning issues

게시 일자: Feb 13, 2025
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While using the Gift Entry, few users in NPSP may encounter the following error: "Secure Query Included Inaccessible Field" when trying to add a Contact or an Account and also, the screen keeps loading.

Note
Make sure your Organization is on at least NPSP version 3.201. (Refer to this Article to check your version), and that you are using an enhanced profile view. 

Steps to reproduce:
1. From App Launcher go to Gift Entry tab, add an existing Contact to the batch.
2. The following error may appear: 'Secure Query Included Inaccessible Field'.
3. Try adding the record to the batch and you might run into another issue that is a never-ending spinner.

솔루션

Root Cause:

The Elevate Payment API Status (Payment object) was added to a query that uses WITH SECURITY_ENFORCED. If a customer does not have read access to all fields in the query, they receive the message. If a customer does not have Apex Class access to GE_PaymentServices (due to auraEnabled method), they are not able to add gifts to a batch.


Resolution:
To resolve the 'Secure Query Included Inaccessible Field' error, grant Read access to the Payment object’s 'Elevate Payment API Status' field:

  1. Go to Setup > Object Manager > Payment Object > Fields and Relationships > Click Elevate Payment API Status > Click on Set Field Level Security > Ensure your profile has access to this field.

To resolve the spinner issue, grant Apex Class Access to the GE_PaymentServices Apex Class:

  1. From Setup > Profiles > Click on your Profile > Click on Apex Class Access > Make sure that GE_PaymentServices is added to the available list of classes.


 

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