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Retaining Salesforce Account Team When Changing Account Owner

게시 일자: Apr 17, 2026
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Key Definitions:

  • API (Application Programming Interface)

  • Apex (Salesforce programming language)

  • WSDL (Web Services Description Language)

Outbound Message Monitor: 

The Outbound Messaging Monitor in Salesforce allows you to track and manage outbound messages that are queued for delivery or have failed.

Root Cause:

Beginning in the Spring ’19 release (API version 45.0), an API option was introduced that allowed the account team to be either retained or deleted when changing the account’s owner. The default value of the KeepAccountTeam option was false, meaning the account team would be deleted. However, this behavior had a bug in which only the account sharing records were deleted but the account team member records were retained. This bug was resolved in the Winter ’21 release. 

 

솔루션

Resolution:

After the Winter ’21 release, when changing an account’s owner via API or Apex , both the account team members and their account sharing records are deleted by default. In order to retain the account team members and their related sharing records, do one of the following:
 

  • Change the record’s owner in the Lightning UI, selecting the option to Keep Account Team.
  • In API  version 45.0 or greater, use the OwnerChangeOption header to set KeepAccountTeam to true.
  • Create a trigger to reinsert the account team after changing the owner.
  • Manually reinsert the account team; for example, using the Lightning UI or Data Loader. For more information, see Add or Remove Account Teams with Data Loader.
  • Use the Enterprise WSDL to specify the OwnerChangeOption of KeepAccountTeam = true, when changing the account’s owner via Apex.


 
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See Also:
Data Loader installation procedure   

Knowledge 기사 번호

000390190

 
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Salesforce Help | Article