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Surveillance d'alerte proactive : alerte de temps d’expérience de la page (EPT)

Date de publication: Sep 24, 2024
Description
Dans Lightning Experience, les pages sont chargées progressivement sur l’appareil de votre utilisateur, composant par composant. Étant donné que les composants peuvent contenir des sous-composants, qui sont parfois chargés après le composant parent, il n’est pas toujours simple de mesurer la fin du chargement d’une page. Nous utilisons une métrique appelée « Temps d’expérience de la page », ou EPT pour exprimer le temps de chargement de la page pour les utilisateurs finaux. Elle mesure le temps nécessaire à une page pour se charger dans un état permettant à un utilisateur d’interagir avec elle de manière significative.

L’EPT est mesuré comme le temps écoulé entre le début du chargement de la page et le moment où il n’y a plus d’activité pendant au moins deux trames de temps (d’environ 33 ms). Les deux trames supplémentaires permettent d’éviter les faux positifs dus à des appels asynchrones. Ces appels comprennent toute activité XMLHttpRequests (XHR), toute activité de stockage, toute interaction utilisateur ou toute tâche côté client de n’importe quel type dans le thread JavaScript principal.

Le produit Proactive Monitoring du plan Signature Success exercera une surveillance pour détecter toutes les valeurs d’EPT élevées enregistrées dans votre organisation et vous alerter de leur apparition.
 

Cause :

Facteurs qui peuvent avoir une incidence négative sur l’EPT :
  1. Performances du navigateur et de l’appareil : Les pages Lightning Experience étant chargées de manière progressive sur le client, elles sont sensibles aux performances du navigateur et de l’appareil de votre utilisateur.
  2. Latence du réseau : Lightning Experience a besoin de réaliser de nombreux échanges Web pour afficher une page, car les données sont transmises du serveur au client et vice versa. Par conséquent, cette interface est sensible à la latence du réseau.
  3. Pages complexes : les pages plus complexes contenant de nombreux champs ou composants personnalisés font l’objet d’un affichage plus lent.
Résolution

Voici quelques pratiques et ressources courantes qui peuvent vous aider à identifier et à résoudre les problèmes d’EPT élevé.
 

Utilisation de l’application Lightning Usage pour consulter les performances des pages et des navigateurs :

Pour mesurer l’EPT avec l’application Lightning Usage, sélectionnez un onglet dans la section Activité ou Utilisation à gauche sur la page. Vous pouvez afficher l’EPT en fonction du navigateur utilisé ou par page.
 

Rapports personnalisés :

Élaborez des rapports personnalisés en utilisant les objets de l’application Lightning Usage.
 

Ajout d’un compteur d’EPT à l’en-tête de votre application :

Pour ajouter un compteur d’EPT à l’en-tête de votre application, utilisez le mode de débogage des composants Lightning ou ajoutez ?eptVisible=1 à la fin de votre URL.  
 

Ressources connexes : 

Ressources d’aide et ressources destinées aux développeurs

Parcours utiles

Numéro d’article de la base de connaissances

000392614

 
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