Loading

Proactive Alert Monitoring: avviso sul tempo trascorso sulla pagina (EPT)

Data pubblicazione: Sep 24, 2024
Descrizione
In Lightning Experience, le pagine vengono caricate sul dispositivo dell'utente in modo progressivo, componente per componente. Poiché i componenti possono contenere dei sottocomponenti, che a volte vengono caricati dopo il componente controllante, non è sempre semplice misurare il momento in cui termina il caricamento di una pagina. Si utilizza come metrica il "tempo trascorso sulla pagina", o EPT, per esprimere il tempo di caricamento della pagina riscontrato nell'ambito dell'esperienza degli utenti finali. Misura il tempo necessario per caricare una pagina in uno stato con cui l'utente può interagire in modo significativo.

Il valore EPT è misurato come il tempo che intercorre dal momento in cui la pagina inizia fino a quando non si verifica più un'attività per almeno due frame (~33 ms). I due frame in più consentono di evitare i falsi positivi dovuti a chiamate asincrone. Queste chiamate includono qualsiasi attività XMLHttpRequests (XHR), qualsiasi attività di archiviazione o qualsiasi interazione dell'utente o lavoro lato client di qualsiasi tipo nel thread JavaScript principale.

Il prodotto Proactive Monitoring del piano Signature Success consente di monitorare e segnalare i valori EPT elevati misurati nell'organizzazione.
 

Cause:

Fattori che possono influire negativamente sul valore EPT:
  1. Prestazioni del browser e del dispositivo: poiché le pagine di Lightning Experience vengono caricate progressivamente sul client, il risultato dipende dalle prestazioni del browser e del dispositivo dell'utente.
  2. Latenza della rete: Lightning Experience richiede molti scambi Web per eseguire il rendering di una pagina, dal momento che i dati vengono trasferiti tra il server e il client, il risultato dipende dalla latenza della rete.
  3. Pagine complesse: le pagine più complesse, con numerosi campi o componenti personalizzati, richiedono più tempo in termini di rendering.
Risoluzione

Di seguito sono riportate alcune procedure e risorse comuni che possono essere utili per identificare e risolvere il valore EPT alto.
 

Utilizzare l'app Utilizzo di Lightning per visualizzare le prestazioni delle pagine e del browser:

per misurare il valore EPT con l'app Utilizzo di Lightning, selezionare una scheda nella sezione Attività o Utilizzo, a sinistra della pagina. Il valore EPT può essere visualizzato in base al browser utilizzato o in base alla pagina.
 

Rapporti personalizzati:

creare rapporti personalizzati utilizzando gli oggetti dell'app Utilizzo di Lightning.
 

Aggiungere un contatore EPT all'intestazione dell'app:

per aggiungere un contatore EPT all'intestazione dell'app, utilizzare la modalità di debug per i componenti Lightning o aggiungere ?eptVisible=1 all'URL.  
 

Risorse aggiuntive: 

Risorse per le guide e gli sviluppatori

Itinerari utili

Numero articolo Knowledge

000392614

 
Caricamento
Salesforce Help | Article