Loading

Supervisión anticipada de alertas: demora de indexado de búsqueda

Fecha de publicación: Jan 31, 2024
Descripción
Si recibe una notificación del equipo de supervisión anticipada sobre una demora de indexado de búsqueda, es posible que su organización experimente un tiempo de búsqueda elevado que lleva a problemas de rendimiento.

Causas:
Esta alerta se desencadena cuando el indexado de una o más entidades está demorado, lo que puede llevar a una experiencia de búsqueda degradada.

Escenarios posibles de demora de indexado de búsqueda:
  • Elección incorrecta de Protocolo API
  • De forma predeterminada, las filas nulas permanecen sin indexarse
  • Filtros de consulta inapropiados
Solución

Estas son algunas sugerencias para reducir la demora de indexado de búsqueda:

Filtros de consulta inapropiados:
Tanto los filtros SOQL WHERE y las consultas de búsqueda SOSL pueden especificar el texto que debería buscar. Cuando una búsqueda dada puede usar cualquier lenguaje, SOSL suele ser más rápido que SOQL, si la expresión de búsqueda usa un término CONTAINS.
SOSL puede convertir en tokens varios términos dentro de un campo (por ejemplo, varias palabras separadas por espacios) y crear un índice de búsqueda a partir de esto. Si está buscando un término distinto específico que sabe que existe en un campo, podría observar que SOSL es más rápido que SOQL en estas búsquedas.

Habilitar indexado personalizado:
Salesforce admite índices personalizados para acelerar las consultas, y usted puede crear índices personalizados poniéndose en contacto con el servicio de atención al cliente de Salesforce. Para obtener más detalles sobre indexado, consulte este artículo.

Recursos adicionales de ayuda y para desarrolladores
Número del artículo de conocimiento

000395622

 
Cargando
Salesforce Help | Article