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Surveillance d'alerte proactive : retard d’indexation de recherche

Date de publication: Jan 31, 2024
Description
Si vous recevez une notification de l’équipe Proactive Monitoring relative à un retard d’indexation de recherche, votre organisation peut être confrontée à des temps de recherche élevés entraînant des problèmes de performances.

Causes :
Cette alerte se déclenche lorsque l’indexation d’une ou de plusieurs entités est retardée, ce qui peut entraîner une baisse de la qualité de l’expérience de recherche.

Scénarios pouvant provoquer un retard d’indexation de recherche :
  • Choix incorrect du protocole API
  • Non-indexation par défaut des lignes nulles
  • Utilisation de filtres de requête inappropriés
Résolution

Voici quelques suggestions pour pallier aux retards d’indexation de recherche :

Utilisez des filtres de requête appropriés :
Aussi bien les filtres SOQL WHERE que les requêtes de recherche SOSL peuvent spécifier le texte à rechercher. Bien qu’il soit possible d’employer l’un ou l’autre des langages pour effectuer une recherche, le langage SOSL est généralement plus rapide que SOQL si l’expression de recherche utilise un terme CONTAINS.
Le langage SOSL peut procéder à la tokénisation de plusieurs termes contenus dans un champ (par exemple, plusieurs mots séparés par des espaces) et créer un index de recherche à partir de ceux-ci. Si vous recherchez un terme distinct spécifique dont la présence dans un champ est pour vous certaine, vous constaterez peut-être que le langage SOSL est plus rapide que SOQL pour ces recherches.

Activez l’indexation personnalisée :
Salesforce prend en charge l’utilisation d’index personnalisés pour accélérer le traitement des requêtes, et vous pouvez créer des index personnalisés en contactant le support client Salesforce. Pour plus d’informations sur l’indexation, reportez-vous à cet article.

Ressources d’aide supplémentaires à destination des développeurs
Numéro d’article de la base de connaissances

000395622

 
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Salesforce Help | Article