Loading

Proactive Alert Monitoring: Ritardo nell'indicizzazione ricerca

Data pubblicazione: Jan 31, 2024
Descrizione
Se si riceve una notifica dal team Monitoraggio proattivo in merito a un ritardo di indicizzazione della ricerca, è possibile che all'interno dell'organizzazione si riscontrino tempi di ricerca superiori, con il conseguente peggioramento delle prestazioni.

Cause:
questo avviso si attiva quando l'indicizzazione di una o più delle entità subisce un ritardo, il che può compromettere l'esperienza di ricerca.

Scenari possibili di ritardo di indicizzazione della ricerca:
  • Scelta del protocollo API errata
  • Per impostazione predefinita, le righe nulle rimangono non indicizzate
  • Filtri query non adeguati
Risoluzione

Seguono alcuni consigli per ridurre il ritardo di indicizzazione della ricerca:

Filtri query adeguati:
Sia i filtri WHERE SOQL sia le query di ricerca SOSL possono specificare il testo oggetto della ricerca. Se una determinata ricerca consente di utilizzare entrambi i linguaggi, in genere le query SOSL sono più veloci di quelle SOQL se l'espressione di ricerca utilizza un termine CONTIENE.
SOSL è in grado di tokenizzare più termini all'interno di un campo (ad esempio, più parole separate da spazi) e riesce a creare un indice di ricerca su queste basi. Se si cerca un termine specifico che è sicuramente contenuto all'interno di un campo, le query SOSL sono più veloci di quelle SOQL per queste ricerche.

Abilitazione dell'indicizzazione personalizzata:
Salesforce supporta gli indici personalizzati per accelerare le query; per creare i propri indici personalizzati è necessario contattare l'Assistenza clienti Salesforce. Per maggiori dettagli sull'indicizzazione, fare riferimento a questo articolo.

Ulteriore assistenza e risorse per sviluppatori
Numero articolo Knowledge

000395622

 
Caricamento
Salesforce Help | Article