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Proactive Alert Monitoring: Search Indexing Delay

Publiseringsdato: Jan 31, 2024
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Search Indexing delays occur when a record(s) is taking some time to be entered into the index table, which can lead to significant increases in the search query time experienced in your org & have a subsequent knock on to productivity.

The Signature Success plan’s Proactive Monitoring product will monitor for, and alert you to, an increase to the number of entities that are experiencing indexing delays. If you receive notification from the Proactive Monitoring team regarding a Search Indexing Delay, your organization may experience high search time leading to performance issues. This article outlines some scenarios to help you investigate should you receive an alert. In addition, on the Salesforce Help site Designated contacts and above can see your realtime metrics, alerts & more.

Causes:
This alert triggers when indexing for one or more of the entities is delayed, which may lead to a degraded search experience.

Possible Search Indexing Delay scenarios:

  • Incorrect choice of API Protocol
  • Null rows by default remain unindexed
  • Inappropriate Query Filters
Løsning

Here are a few suggestions to reduce search indexing delay:

Appropriate Query Filters:
  • Both SOQL WHERE filters and SOSL search queries can specify text you should look for. When a given search can use either language, SOSL is generally faster than SOQL if the search expression uses a CONTAINS term.
  • SOSL can tokenize multiple terms within a field (for example, multiple words separated by spaces) and builds a search index off this. If you’re searching for a specific distinct term that you know exists within a field, you might find SOSL is faster than SOQL for these searches.

Enable Custom Indexing:
  • Salesforce supports custom indexes to speed up queries, and you can create custom indexes by contacting Salesforce Customer Support. For more details of indexing refer this article.

Additional Help and Developer resources
Knowledge-artikkelnummer

000395622

 
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